New wifi wont link to currents cams

I got a new Wifi with a new account name and new password but none of my cameras can find my account, I get Error “cannot find the specified acct name” and “cannot connect to local network” Why? My laptop, phone, and TV accept the new info but not the cameras? Help!

Before you ask, the account name and PW are correct, it is 2.4 GHZ and WPA2/Personal security. I am having the same issues with all my Cam2 and Cam3 cameras

What’s the ssid name? Does it have any special characters in it other than letters and numbers? How long is the password?


The cameras cannot take a new SSID or password unless you completely reset then from scratch.

I would encourage you to instead reconfigure your router to use exactly the same SSID and password as the old one did.

1 Like

I did a complete factory reset, as per trouble shooting guide , and it still won’t connect. It finds the ssid just fine, it appears as first item in available wifi list . Name ID has no special characters and password is 8 in length, no special characters. I have no personal control over wifi, can’t make adjustments, need to call cable company to do that.

Can you post screenshots of the errors?
I’ve never seen “cannot find the specified acct name”. Not dure what Account that would be referring to.

Cant get a screen shot, it is the voice prompts coming out of the Cam during setup procedures.

Even after using factory reset, I was not able to connect to new network name. But I was able to get my network renamed to old one and now I can connect. Thanks for your help!

This certainly seems like bad programming to force us to do have to use only original name. That means if I give my old cam to a friend, they wont be able to use it. This also means you cant resell a cam to someone else. That’s just ridiculous! Gotta be a better way.

I have moved V2’s and Pans between networks of different ssid’s from my first cams to about 6 months ago. Just did a reset and they worked.
I’ve given about 10 cams to relatives with different networks, no problem.


What was your new ssid name that you tried to use?

I’ve moved cams from one ssid to another several times, what you are encountering is not normal. There is something quirky with the new ssid or something going on that is causing you issues.

1 Like

Probably just needed to temporarily turn off mobile data and / or the “private network” block during phone setup. Good to hear it’s working again. (I’ve never heard of an ISP router with an unchangeable SSID.)


Neither did I before Optimum online cable service. You rent it but they control it.
Had to call , wait in long que before I could get them to change it.

1 Like

Okay. A quick search says you can go to to change it yourself, but I’ve never used the new service.

You’re coming to the wrong conclusion based on one experience.
None of that is true. You can resell, move, reconnect cameras as many times as you like.
I move two cameras between my home and cottage twice a year and connect to different networks.

Except the Wyze Cam Outdoor makes it more difficult from what I understand, since (only with that model) the cameras can’t be resold without removing them from the account. I think.

1 Like

Ah, the Apple matality. No Outdoor cam for me.

It’s just a (silly in my opinion) antitheft measure. You can still sell the camera if you do it right. There are a lot better reasons to avoid the WCO model. :wink:

1 Like