Why is doorbell not announcing on Alexa?

My video doorbell is not announcing on my Amazon echo devices. My other cameras work fine with them but the doorbell. I can view the camera and that is it. I use the Alexa’s to announce to the entire house when the doorbell rings and now it can only be herd outside the house which is useless. Please help me fix it. And no there is not anything wrong with the Alexa devices, just the doorbell. Thanks.


I noticed this happening as well in the last few weeks and haven’t solved it yet. I haven’t had time to try it, but it’s possible removing and re-adding the wyze skill will fix the problem.

1 Like

I did tried that and didn’t have any luck.


Try one more time. But this time, leave it disabled an hour or more. Then re-enable it.

same thing on google home hub.

1 Like

Not sure how you have it set up however, I do not use the “Doorbell Press Announcement” in the device itself. I use a routine which is triggered on press of the doorbell. I can then customize what it will say.

Have you tried it this way? I don’t have any issues by doing it this way.

I don’t have a wyze doorbell but
I had to set up routines for couple of the main cameras I rely on for announcements on my echos because regular announcements that you set in cameras in Alexa no longer work, the routines I set up do work though.
But I guess the point is the announcements that used to work no longer do


I have had the same experience. I have the VDB, but I don’t use the announcement feature as the names I used get stated in the announcement. I wanted to customize that.

So, I tried to set up an Alexa routine but it only will announces on one device. I used it to announce on four different devices throughout the house. It works, but only in one room. If I am upstairs, I’m screwed. It used to work perfectly with the announcement feature?

1 Like

Use the announce and not the alert of message, not sure which one it is. I will look for you. I have mine announce on 5 devices.

So you need to scroll down to messaging,select it, then select announcement. You can select multiple devices from here

Thanks for the help. It does seem like it would work but my doorbell is not talking with Alexa at all? I can not view the camera on my echo show and when I set up the routine, there are no responses from the devices inside the house. My other cameras work fine. I don’t know what’s wrong but basically my doorbell is worthless right now. If anyone can help, please let me know.

Not sure if I just missed it, did you delete the doorbell from Alexa then do a Device Discovery again.

Also, are you part of the Beta Group testing the Robot Vacuum? If so, it will add another Wyze Skill under the Dev Category. This has affected others as it added duplicate items. I had to delete the duplicate items.

1 Like

I retried that just now and no luck. Thanks for trying. I need all the help I can get.

1 Like

I think its a good idea every so often to disable/re-enable the Alexa skill. I have to with my Samsung stuff too. I think the skill gets updated by Amazon or Wyze and reapplied to their server. So, I believe the commands sometimes lose their sync to our devices. The good news is sometimes it works sometimes it does not - but it cost nothing to do it.

1 Like

Thanks for trying to help, but that was one of the first things I tried and It didn’t help. So far this is costing me time and money. The money I spent on a useless doorbell and the time it is going to take to replace it. A doorbell that does not ring inside the house, is the most worthless thing ever!!!

Is there a reason you can’t use the included chime? It took me all of 30 seconds to switch back to it after the echo’s stopped announcing presses.

Yes there are a few reasons. First I bought it to use with Alexa. Second, it only came with one, which I cannot hear throughout the house. Third, the lady of the house did not like the rings that were available with the chime, so it has never been used. I hope that answers your question.

1 Like

This is one of the first things I checked when switching from a Ring doorbell to the Wyze doorbell is to make sure it rings on my Alexa devices. I had to install the Alexa Wyze skill, then link my Amazon and Wyze accounts. Once that was done, in the Wyze skill settings inside the Alexa phone app, I configured it as shown in this screenshot.

Yes, when someone presses the doorbell, all my devices throughout the house go off, mass pandemonium with out of sync announcements, and the dogs go crazy. But I never miss anyone ringing the doorbell. :grin:

The only issue I have is that I can see all of my Wyze cameras on my Echo Show except for the Wyze outdoor battery camera and the Wyze doorbell. No idea why those cameras won’t work as they are listed in the Alexa app, but say “Wyze - Live view not supported”

For me, this worked for months after getting the doorbell, but recently it just stopped and nothing seems to get it working again.