When imported to iMovie, the sound is gone or just noise

I imported a few videos today in order to trim them and join them into one. The sound is mostly blank but with occasional squeal/click noises. Any thoughts on what to do about this? The files were dragged from the card to my HDD, then into the iMovie timeline editor. They play fine just using Preview in Finder and in VLC.

I tested a few other MP4 files, and all of them worked fine (sources other than Wyze cameras). I haven’t tried another editor, not sure what I’d use. I almost never screw around with video files like this.

It is almost certainly the non-standard audio codec the cameras use. You can transcode to a more standard format with VLC or ffmpeg.

The cameras oddly use 8 bit a-law G.711 codec.


Thanks, and that’s interesting. It’s an odd choice, but I’m also surprised at how many products can’t handle it since it’s such a simple CODEC. I tried a conversion in VLC to MP3 audio in an m4v container, and now it’s just silent. I give up, it’s not important enough to keep trying.


This is still an issue :roll_eyes:. No sound or crackling sound when importing video into imovie. looks similar to this issue on reddit: Reddit - Dive into anything