When a V3 refuses to Setup (Stalls on QR code) - potential workaround

TL;DR: If you have a V3 that won’t activate to your router, try to activate it on a different router, or your mobile hotspot, then update to the newest firmware (alternatively follow the guide to manually flash the firmware to the newest version), then reactivate the cam to the correct router and it should work.

I had a V3 that refused to setup on my router. I had several other devices that work just fine on the router, including Pan Cam, several V2’s, and several over V3’s, as well as other devices. I had one V3 that just wouldn’t activate though.

I would get through the entire setup, scan the QR code, and it would always timeout. I activated other cams both before it and after it, but no matter what I did, it would not connect to the router. I went through ALL the troubleshooting with Support…and let me tell you, there was a LOT. I must’ve retried the setup at least several dozen times, probably over 50 times with different variations. It was infuriating. Support kept telling me my router was the problem, but all my other devices worked fine, and I could set up other new devices, just not this particular cam. I was hoping to exchange it, but they kept pushing the router issue, and interference issue, etc…but if those were the case, then other V3’s would not activate either, and they all did just fine. It made no sense.

Eventually, I enabled the WiFi hotspot on my old deactivated cell phone (so it had no mobile data, but was connected to the same WiFi router that the cam couldn’t activate on, so technically it was just like using the same router it was failing on), then setup the V3 to connect to my cell phone hotspot, downloaded the new firmware to the V3, then re-setup the device on my WiFi and it worked perfectly fine!

So, the problem apparently had something to do with one of the earlier firmware versions not liking something with my router, but not minding my hotspot (basically a bridge to the same router), then after upgrading the firmware to the latest [beta] firmware, the cam now activated directly to the router just fine. So I did not have to make any changes to the router, just the cam firmware, which indicates the firmware has a flaw in it that sometimes prevents the cam from activating in some circumstances, but the newer firmware has somehow fixed that.

So again, if your V3 won’t activate on your router (but other devices will), try it through a mobile hotspot, or another router, then upgrade to the latest firmware. Then do setup again and it should connect to the correct router finally. At least it worked for me after 50+ attempts of everything else.

1 Like