WebView will not load/play some videos

I have Cam+. I just recently started noticing on WebView that some videos will not load and play. The video window opens, but it just displays the rotating sun icon. Only about 1 out of every 10 videos plays. There doesn’t seem to be any pattern. I went back two weeks (the max) to see if it started on a certain date, but there isn’t a day where it does not happen. I don’t have an issue on the phone app. Has something changed on WebView?

I tried closing my browser as well as rebooting, but it still happens.


For the last two days the events on webview have not worked at all on my computer.

1 Like

Ditto. Last 2-3 days – endless sun only.


rarely works for me as well. I would have to keep reloading the webpage and trying each camera. some will load and others won’t. Not sure if it’s a v2 problem but it’s getting on my nerves.

1 Like

I’m having the same problem. It works on my android phone but not on my office computer. Does anyone have a suggestion on how to get this thing functioning?

1 Like

I have tried:
– resetting camera (via app)
– hard-reset on camera (power cycle)
– updating and rebooting my computer, router, etc.
– switching browsers - tried chrome, edge, firefox (like misc619, it works on android, but not on laptop where I need it)
– clearing cache on browser
– waving chicken over head and stomping three times
No joy.
I was told by support that they are aware of the problem and working on it – no time estimate or prediction of success.


Same problem for the last few days. Wzye app on ios works fine, but if I try to view an Event from the web browser, it just hangs indefinitely. Live view on the web seems OK, it’s just the Events that hang.


It’s to the point to where I have my main security camera on a wifi outlet so i can power cycle it when it goes offline.

I have the same issue. On the App everything works fine - can view live, can view and playback events. However, on webview there are problems. Live is fine on Webview . I can see all the Events but many do not playback. I noticed that if the Event is the default 12 secs or less, it plays back on Webview on laptop but anything greater than 12 secs just spins and doesn’t ever play. Tried clearing cache, different browser, incognitio, different laptop but Events don’t play back - been like this for about a week

I have the same issue here. Can use webView to view live stream but when viewing the events, all I see is the spinning wheel. It’s been like this since Feb 28! Very disappointed! I have tried it on Apple and other PC platform as well. Same issue! All Wyze said is the engineer is working on it! Who knows what’s going to happen.

Maybe it is still a Beta of a Beta :upside_down_face:

Whatever the problem was, it looks like it is fixed. All event videos are now playing successfully.

Not quite yet! I can only see the last 3-4 hours of each day’s events. When I strolled down further, the loading of the earlier events won’t load. Just the spinning wheels over and over again!

That’s true. I didn’t check that before, but I see it also. Well, at least it’s progress. Maybe in another week they will get that fixed also.

I went back a week, and it still worked… maybe?