Webcam flashing instruction are horrible

  1. Download the webcam’s special firmware here.
  • Windows 10: Right-click on the folder and select Extract all .
  • Mac OS: Drag and drop the folder on the root directory of your microSD card.
    • For both Mac and Windows, rename the file to demo.bin .
  1. Unplug your Wyze Cam from power and insert your microSD card.
  2. Press and hold the Setup button, then plug in your USB cable. USB A TO A OR THE NORMAL MICRO USB? Continue holding the setup button for 3-6 seconds until the light is solid blue, then release the button. LIGHT BLINKS ONE SHORT BLUE THEN CLICKS AND ANNOUNCES READY TO CONNECT
  • Note: The “Solid Blue” in this case is not the same as the one normally seen on the camera. Instead, both the blue and yellow LEDs will be on at once, appearing as a lighter blue.
  1. Wait 3-4 minutes. The camera will reboot, and the light status will change during this time.
  2. Once complete, the status light will flash yellow and blue at the same time (not alternating).
  • Note: Wyze Cam will continue to flash yellow and blue at the same time if the webcam firmware is installed properly and the camera is turned on.
  1. Connect the USB A to A cable to the Wyze Cam (USB port, not the micro USB port) and computer USB port.
  2. In your video conference tool (ex. Zoom), change the camera source to “HD USB Camera.”
  • We recommend you use a different source for the speaker and microphone functions.

extract the demo.bin to your desktop, then copy to the root of the sd card…it must be in the root, not in a folder. sd card does not need to be formatted. just eject from your cam & copy the file.

using the micro usb power cable, make sure it’s unplugged then press & hold setup & plug in the cable to power up. keep holding the setup for about 5 secs, follow the rest of the instructions


Thanks, I suspected that was the case and was doing that. The issue turned out to be the size of the MicroSD card. My cameras have always worked fine in normal operation with the 64g cards that I had laying around even though the “official” size is 32g max.
Well, that came home to roost. I was using the card from the camera a 64g. For reasons that are above my level of expertise, that 32g limit seems to be enforced for flashing firmware. In hindsight that seems technologically very reasonable and I should have expected that behavior.
Using Windows Disk Manager ~
Deleted the card’s volume
Created a New Simple Volume of 28g (28672 mb)
Chose FAT32 for the File System
Formatted it
Went back to the flashing instructions and when it got to the point where I was just getting a single quick blue blink, this time the light remained blue. From there the process was successful.
Thanks for the answers and clarifications, I was stumped until I realized what I did. I hope my work around is useful to folks if you don’t have a “proper” size card available right now during this …well you know.

( I stand by my title however, the instructions need to be far more detailed. Especially if this is aimed at non tech folks who have been forced into a remote situation and are not even slightly aware of the concept of “flashing firmware”.)

1 Like

Seriously, who even owns a USB A-to-A cable any more, or ever?

I have many, that’s not an issue for me. My issue is locating the box I put them in years ago lol.

1 Like

Got a Wyzecam that stop working, reflashed it and came back alive as a WebCam just fine!!!
My specs: Mint (Linux) without driver needed. Used it with Zoom app.

Same-o here. I knew i had at least one around somewhere then this morning at like 3 am remembered that it was in my wife’s truck as an old dashcam power cable. I then went to her truck and ripped it out to use as for my wyzewebcam.

I had some trouble with the rename the file direction. It just showed “demo” over here, so i renamed it “demo.bin”. Well i guess that renamed it demo.bin.bin and i didn’t realize it for a while. No need to rename the file. Figured it out and walla, worked on two cams that i had sitting around.


Sounds like you were using Windows to rename the file. The best way to rename a file with a suffix is with quotes around the file name. (EX: “demo.bin”) This tells Windows to name it exactly what is in the quotes. :slight_smile:


Good advice but the point in this situation is Wyze is telling us to rename a file that doesn’t need to be renamed.
Inexperienced users are seeing a file named demo and thinking Wyze says this should be demo.bin .

1 Like

Yep, I agree with you. I think their tech writer was basing their instructions from other firmware flashing instructions in the past. I have brought up the issues with the instructions with Wyze already. :slight_smile:

1 Like

Yes, the instructions seriously need some QA Testing and a rewrite. I’m very experienced dealing with computer stuff, but I was left scratching my head about parts of the instructions. Also, the instructions that are packed with the bin file are slightly different than what is posted on the web page. I’m very grateful for the work, but a couple of hours to smooth the rough edges would have been nice too.

So I had the same problem with my Wyze Cam v2 and a friend that bought one as well. What I ended up doing to fix my issue was installed the Wyze app on my phone and connected to the camera as a normal security camera. Inside the app I went to to advanced settings>local storage and formatted my sdcard from here. I also made sure to eject the sdcard using the app. Then I put the sdcard back into my computer and copied over the firmware. I then put the sdcard in my camera and while holding the reset button connected power. This allowed my camera and my friends camera to boot to the sdcard and install the firmware. By the way, I successfully used a 64GB sdcard to do this so the camera will work with a 64GB sdcard.

MicroSD must be formatted to FAT, not exFAT

Mine is 64GB