V2 Black - Can't flash [any] firmware


I have a number of the Wyze Cam V2 Black’s from HomeDepot’s Black Friday. With everyone stuck at home these may better serve has webcams.

Firmware updates within the app work without a problem, but attempting to manually flash any firmware through SD just isn’t happening. Bin file is loaded on the root of the SD card, power is cut, SD is inserted, setup button is held, power is connected… and we just get a solid yellow until the yellow flashes and i hear “ready to connect”

The SD card works fine as I can record to it via the webcam and access it via PC

Other notes:

  • The SD cards I have are 64gb, not 32. Is 32 required?
  • Yes, I’ve properly hit the button
  • I’ve tried this with both the microusb and USB a-a cable as power sources
  • I’ve tried multiple firmware’s to see if it was just the webcam one. Issue persists
  • I had a fresh camera still in the box so I cracked that one open and ran into the same issue

So the questions are

  • What did I miss?
  • Has anyone else been able to manually flash firmware on the V2 Black?

Appreciate it the help!

1 Like

Welcome to the forums! For clarification, you said you’ve recorded to the SD card while using the webcam firmware? I believe that if you have the webcam firmware successfully installed, you camera is now a webcam only. If you want any other Wyze camera function back, you need to flash back to a production firnware. I’ve heard that you need a 32 gig or lower SD card to install firmware, that might be your issue. I’ve has success flashing firmware to the black cams.

I’d get a 32 gig card and I think you’ll have success.


Thanks for the response! This is one time where I may be cursed with having SD cards that are too large. I’ll go digging around and report back

1 Like

Hey Tony,

For clarification, I am unable to manually install any firmware on these black cams I have. I had recorded video to the SD card with the factory installed firmware just to ensure the card was recognized and working with the camera.

I went rummaging around after your last reply in search of a smaller SD card, as the one I was using was 64gb. Unfortunately I did not find a 32gb card, but I did find an 8. My issue persists.

I can’t get the blue light to come on after holding setup and connecting power. As the instructions state…
Disconnect power
Insert SD card with demo.bin file on root
Hold setup button
Reconnect power
Wait 3-6 seconds for light to turn blue <<this part never happens for me

All I see is a solid yellow light after connecting power with setup button depressed. After more than 6 seconds the light will start flashing yellow and then I hear “ready to connect”

Thanks again for your time and responses. I greatly appreciate it!

1 Like

I had watched several videos trying to figure out what I was having trouble with, and I found this guy’s video helped me personally the most (plus we share the same hairdo).

I used a type a to type a usb cable plugged into my computer for power instead of the supplied Wyze USB cable and wall charger. When it got the firmware installed I did nothing extra and I knew it was done when the computer recognized it as a “hd USB camera”.


Haha I’m not too far off on the hair do myself. I’m getting closer and closer every year

It was good to see someone walk through this setup by step. Unfortunately for me, I just can’t get that gosh darn blue light to come on with either power cord or SD card that I have.

I’m still suspicious of my available SD card selection. I’ll report back if I happen to come across one and try with the 32gb variant

Thanks again!

1 Like

Following up to mention that it was indeed the SD cards. 64gb was too big, 8gb was too small, but a 16gb worked just fine

Thanks for the support!


Hi everyone, my issues is this:
I needed for the time being a webcam so I took my working V2 white camera and proceed to download the firmware and apply it to the camera successfully, Now I do not need the webcam but I have tried everything to restore the cam back to factory settings with no luck, I already spoke to customer service but they were not able to help me with the issue, Yes is out of warranty and I purchased this on Amazon.
Doing a simple restore has become very difficult on this camera, Did someone found a solution
to do it successfully? After everything I tried a blinking blue light is what I get.


You need to do the manual firmware flash (the same process you did to put the webcam firmware onto the camera in the first place) to put the production branch firmware into the camera. A factory reset won’t do that.

Here is the manual flash instructions again:


I was having this exact issue. Every time I tried flashing the NEWEST firmware, I couldn’t get the cam led light to stay on steady blue, it would flash and never update the firmware. Then I tried the “demo_4.9.7.798” and it worked the first time. Then I was able to update to the newest firmware through the app.
Hope this helps any of you trying to manually update the firmware after using the webcam firmware.

1 Like

Yes, tried that already. I downloaded the firmware for my V2 camera, grabbed a 16bg microSD… formatted the card load the file renamed (demo.bin) but it does not work, I also used a 64gb microSD with same result. I was told by customer care that a 32gb is needed, its that the case?

Edited: For some reason I only saw 2 different firmware files but there are more than 2, So I tried the one LightningGA said and voila… it worked,

1 Like

Thanks, your post helped me, Issue resolved

1 Like