Watch 47 - Sync and Data issues

Hey all,

I’ve got a Watch 47. It’s been a bit funky, so I did a factory reset and it’s been good since. However, when I sync… is show the progress, but hits 100% and stops/hangs, but never shows “Connected.” Also, the data says it’s coming over, but I can’t see any recent data in the app. It stopped showing data a few days ago. It’s like the Watch and the App no longer work together. I’ve deleted and reloaded the app… no luck.

Any advice on how to get the data working again… and to also have it sync and connect?



Call Support…I tried and tried to like this watch…It’s needs LOTS of help. I put in the draw and using my Samsung.

1 Like

Mine started doing that as well. It gets to 100% and then says failed to connect. (To be specific, that’s when you open the watch in the app.) If I try it three or four times in a row, it works again. I also noticed that if I turn the watch face off (I have raise to wake turned off to preserve battery life) then it will be more likely to connect. I’m not sure what is going on, but it is a relatively new issue.

1 Like

Go to System Control → Restart Then reacquire the watch from main App screen.
The Watch Data is stored in the AWS cloud so even if you delete and install the watch, the data will persist.

Tried this already a few times… no joy. The watch is collecting the data, but it’s not getting into the app. It still stops at “100%” but never shows connected… and no data to the app. All was good until this last firmware update.


Have you tried delete the watch from App, clear cache*, reboot phone and then install watch again?

  • Account Tab → App Settings → Cache File {Clear}

Yup… tried everything I can think of. Watch is collecting the data, but the app doesn’t see any data past June 12.

Wow, thats quite a long time! I suppose you’ve tried Factory Reset on the watch.
The Bluetooth is on and App is running in the background. I have firmware version 0.12.49
Perhaps @cohibajoe has the right idea, give Wyze Support a call. . .
206.339.9646 8-4 Pacific on Saturday

During app sync, it seems to perform ok. Status 100% and connected. The app will display current stats on summery page but when I look at a stat detail, there is no data under the today page…the weekly does show past data but nothing on today. It used to work just fine…


Have same trouble on but am using the Beta App for Android. Sometime the Activity page is not fully populated. It is not consistant so thinking it may be a problem on the AWS server. :woman_shrugging:
After closing and reopeneing the App a few times data is restored. Seems to work OK after that, I shut the phone down at night. :slightly_smiling_face:

1 Like

Well… I tried the one thing I hadn’t… rebooting the phone. That seems to have done the trick. It still doesn’t always show “connected” …but it seems to be, and data is coming back across. Odd.

Hi @cclement1968 Still good idea to call Support so this can be addressed in the next update. Thanks for the feedback! :slightly_smiling_face:

This started for me after the last app update. (android) about 2 weeks ago? I don’t recall the app version number. Tapping retry a few times fixes it.

That seemed to work… I did 4 app shut down/re-start cycles to get the data to populate. Interestingly, when I checked my sleep, there was nothing, I checked my steps and there was data… a re-check of sleep and now there is data… Something ain’t right…
BTW, this is regular app running on iOS.

Seeing the same issue with sleep data. takes 2 views to see the nights sleep in the morning.

1 Like

My 47 is in the draw…Samsung back on the wrist. Wyze Wyze Wyze…focus on a Core Product group.

1 Like

I did also but just too many glitches. Finally put it away and will keep my eyes open for something better.
Different subject but spent 2 hours + today attmpting to update Wyze to22.2 from 22.1. No luck. I could go on but basically I have had it with this outfit. The scale works OK though.

Thanks for reading.

1 Like

Same problem with Watch 44, firmware 0.3.90, plugin v.1.1.46: “Syncing data” counts up to 100% and…stays there. No data. Reset watch, powered it down and restarted, forced-quit the iOS app (v2.22.21) and restarted, rebooted the iPhone. Nothing seems to help. However, from time to time, some of the data (steps, calories, occasionally heart rate, but not sleep or Sp02) shows up under weekly, but not daily. And then at some point, most of the data does seem to show up after a day or three. Weird!

The fact that the same problem appears in both watches, which have different firmware, suggests that it’s a problem with either the app or perhaps the common syncing code in the firmware.

I noticed that the SpO2 reading I just took shows up in the Activity summary at the correct time, but when I tap for detail, it shows a sad face and no data.

Same here as everyone else. It will show no sleep data, but when you click on it, it shows a sad face. I click the left arrow to see the day before, nothing. I then click the right arrow to go back to today, nothing. I click the left arrow, it shows up. I click the right arrow and nothing. I think click the left then right arrow and then last night’s sleep data shows up for today. Not sure if it is a syncing issue, app issue, or firmware, but this is all getting old. Wyze needs to stop releasing new products and fix the existing ones they have. They have the potential to be a great and powerful company, but if they don’t fix this stuff they will lose their core backers that helped get them to where they are today. Once they lose those people, their company will get a reputation; one that will not make them a sustainable company.

How do you do a factory reset on a 47 watch? Mine has been down for a couple weeks now, says it’s charging, says 100% but doesn’t start again and then says 0% after one attempt to start, then back to connect to charger. Never boots up.