Video recordings all freeze between 2sec and 10sec

Anyone having issues where all their video playbacks freeze at approx. the 2sec mark and stay frozen until approx. the 10sec mark? I know this is not a wifi or camera specific issue, as all cameras in two different states on two different WiFi’s have this issue.

Any ideas on how to fix?

Thank you.


This is a known issue Wyze is working on.

Could you give me a bit more info so I can let Wyze know, they are trying to figure out why it’s still happening to some.

What cam models are experiencing this.
What FW and app version(s)
Are the cams on a floodlight, GDC, or lamp socket?

Is this happening on cloud events (events tab) or SD card playback (green playback button)

1 Like

Thank you for the response. I have multiple: three wyze cam V2 running FW- Three Wyze Cam V3 running FW- All of those are plugged into wall outlets.

I have one cam “Wyze Outdoor Cam” running FW using a solar panel charge that appears to NOT have the issue.

I have not had recent recordings on my pan/scan cams, but will try and run test in near future.

Thank you.

All events are recorded on cloud.

1 Like

The v3 cams are running Can you send a screenshot of the FW page, that doesn’t seem right

So sorry, I read the wrong line. V3 has FW- Sorry for the confusion.

It’s Feb 28, 2023. This issues seems to have been going on for a while. I have owned a lot of Wyze cam’s. One of my V3’s hangs like this. It’s WiFi signal is strong (minus 1 bar only). It’s FW is up to date. It begins recording upon being triggered by cars going down the alley, It hangs although the progress bar keeps moving. Eventually, the car jumps to the far side of the frame having missed many seconds of video. This greatly impacts the usefulness of the camera. Where is the problem? The Camera ? The web-based storage?

1 Like

Interesting, that’s the most up to date firmware, so it shouldn’t have that issue.

Mind getting a cam log in the cams settings > Wyze support, and posting the log number here.


952651 - log number. This is from one cam. If need others, let me know. Problem is similar for multiple cams.

1 Like

Since I upgraded to Cam Plus, my v3 camera only records 2 seconds of video, just a fraction of the motion events. The Events screen says the videos are longer: 13 seconds, 15 seconds, 14, seconds, etc. But when I try to view the videos, they are ALL only 2 seconds long. This only started after I added the PAID subscription service. The free service worked better.
Log 953001.
I feel like I have been robbed. But if I had actually been robbed I’m out of luck because all I have is a 2 second, incomplete video.
When I tried to get help with it, the support people kept saying “So you’re not getting any video, right?” Like they were not listening to the multiple times I told them I get only 2 second long videos.

Thanks for the log. A fix will be coming to beta very soon, and if it passes beta it will be released to everyone.

Keep your cam and app updated and hopefully it’s resolved

What you told me has been said for two years. Is there any evidence that the issue will be fixed this time? I always keep my software and firmware up to date. It’s extremely frustrating that this problem comes up after I choose to support this vendor with a paid subscription.

The lack of actual support from the support staff is indicative of a failing corporate culture.

1 Like

I don’t work for Wyze, I’m a community volunteer.

This is primarily a user to user forum, but Wyze staff do pop in from time to time. Wyze support at is the best way to get in contact with Wyze staff, however they don’t always have a lot of insight into issues that are being fixed.

If you keep an eye on the beta section of this forum you can see when Wyze posts bug fixes and you can track their progress from there.

1 Like

I have the same issue. Started after I purchased the cam plus. 3 seconds then freezes. The bar keeps going and the video then catches up at around the 10 second mark then sometimes finishes till the end or if it’s more than 20 seconds long, it will jittery till the end. Yes I have gig Wi-Fi with Xfinity and all FW is up to date. I’ll follow this thread until there is a fix. But just so Wyze knows, I’m not purchasing another camera until or if this gets fixed.

Try pulling the power cord on the camera for a few seconds and see if it helps.

That helped for me, but I only had one camera affected.

1 Like

Thanks for reminding me. I tried that on both cameras but no fix.

Hey @robertmccauley many of us are experiencing this same issue. Firmware in device? Bad build of the app? Something on wyze servers? Nobody really knows except the actual product engineers. They’ll fix it at some point. it’s clear that this wasn’t a problem, and now it is a problem for many users, so they’ll do regression testing and figure it out at some point. No i don’t work for Wyze either. But I do see bugs often that go away 2-6 weeks later.

I have the same issue. When i was on the free service no issue but once i signed ip for the payed service boom the freezing started. Very frustrating. If wyze doesn’t fix the issue i feel they should refund for the cams and the service.

No the issue isn’t the internet or the amount of items connected to my internet. I have 2 different places one has 500 gb service the other has gigablast and both have issues.

Been having this issue for several months. Very annoying.

Guessing it is the AI logic server-side? If people say the hestitation is not there unless you pay for the AI – people, pets, trees – then perhaps that is the issue, and they need more server horsepower on the back end to process all the videos?