Vacuum - can anyone diagnose my problem? It won’t light up, can’t access it, app says stuck in standby

My Wyze robot vacuum has had no issues with battery and been working fine. After finishing vacuuming and starting to return to the base with 50% battery still left, I stopped it with the app and went and picked it up a few minutes later and moved it back to the base. Then six hours later I received a message saying something like your vacuum is turning off since I isn’t been charged for like 6 hours.
I took it off and on the charger many time, no lights are on the vacuum. I’ve hit And held the different buttons on it many times and still no lights. I can’t access it in the app as it says “standby” for its status. It doesn’t seem to charge or come on. Charger base light is on and touching it with multimeter shows 20v at the chargers connection points.
Anyone have any ideas?
Is it the battery?
In the app it shows the location where I stopped it, before I picked it up (so it’s not recognizing I put it back on the charger).
I did take it off the charger again, and 6 hours later I received another message saying it’s been not charging for 6 hours so it’s shutting off (even though it never came back on and was just dead the whole time).
Any ideas?

Clean the contacts with isopropyl alcohol, it’s good to do as regular maintenance.

Have you tried disconnecting the battery for a while?

1 Like