My robot vacuum died, help!

Hi all, I have 2 robot vacuums. One of them died. No lights, won’t charge, no disconnect info. Was lit up yesterday but not used, and today, deadsville. Was against the base all night. Nada. Holding either button for 30 seconds separately, or together, nothing. I have no deal what happened. Tried wth other base nada. Any ideas? I would guess a fuse on the circuit board blew. Only used about 20 times, was great before this. Thanks for any ideas.

Welcome to the Wyze community @GaryGnu!
Have you tried holding down the power button to power it up? If the vacuum shows no sign of life, you may want to contact Wyze Customer Support about this issue!
By phone: (206) 339-9646 Available Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT
Or online:
phone support is typically faster however this isn’t always true due to fluctuation in the amount of calls.

The 120v outlet working?

I believe I’m having the same issue with mine. Has worked great for the last 10 months then went dead today. Can’t tell if it’s not charging or something else.

@GaryGnu Did you resolve your issue?

Try holding the power button down and see if it turns on.
If not, make sure the charger and outlet are working. If all seems normal, You may want to contact Wyze Customer Support about this issue!
By phone: (206) 339-9646
Or online:
Wyze Support has extended their live support hours for a better support experience. ( Excluding Holidays & Emergencies )
Monday - Friday 4 AM – 8 PM PT

Saturday 8 AM – 4 PM PT

I contacted Wyze and we were unable to diagnose the root problem. But they were able to get me out a replacement unit, awesome service on their end!

Glad it worked out :smiley: