V3 AI Detection toggles broken since last firmware and app update

I’ve had few issues with any of the three V3s I purchased last April…until the latest firmware and app updates were forced upon us, whereupon all of the AI Detection toggles/switches on my one CP-subscribed camera quit working altogether, and each toggle instead returns an error (as described below). I submitted a log and posted in support, but I’ve heard nothing at all in response. I’ve not seen anyone report my specific issue/error; nonetheless, I am in the same boat as myriad others who have no functioning AI notifications. Here’s the pertinent info as submitted:

LOG ID: 431984, submitted 1/11/2021
Updated Android app to 2.27.33 as ‘mandated’ and now whenever I attempt to set any Cam+ AI detection settings (ex. Person Detection, Package Detection, Vehicle Detection, etc.) in the Smart Settings section of the app, the setting will not toggle On, and I get the following error:

Face Recognition Open Failed: {“message”.“Bad Request”,“response”:“The specified collection id is invalid and/or does not exist for the user.”,“status”:400}

As it stands, I’ve rebooted the camera remotely several times after turning off all notifications and restoring same after rebooting to no avail. I’ll not be on site with the camera for another week whereupon I can play with them in the flesh, but I’m hoping somebody might have one or more troubleshooting suggestions that might return AI Detection function.


You can try a couple of things, I have in the past with success :

Option 1

There has been toggle issues in the past and some have reported it recently. Go to your notification area and turn off all notifications (AI and the master Notification Toggle). Then go to the Event Recording, go to the Smart Detection and turn off all Smart Detection Settings. Back out to the main event recording menu and toggle off Detects Motion and back out again to the main settigns menu.

Now, go into Event settings and do the reverse. Turn on Detects Motion, Go into Smart Detection and turn on which AI Events you would like to detect. Back out to the main settings menu. Then go into Notifications and turn on Notifications and turn on Wyze AI Events.

Option 2, something else to try

Go to Accounts menu, bottom right. Click App Settings and clear Cache. Back out one menu and scroll to the bottom and select log out to log you out of the app. Then, restart the phone. Once the phone comes up, start the app, log on and see if you can get notifications


Hey, thanks for the reply. I’ve performed all of Option 1 already coupled with camera reboots…several times, and I’ve tried various On-Off (Motion Detection+AI) feature combos…all to no avail. I’ve also cleared the cache more than once trying to rectify this error, but I hadn’t logged out of the app.

As it stands now, I’m waiting on a callback from my ISP due to a lost internet connection, and once my ONT has been re-provisioned I’ll try all of Option 2. I’m also considering uninstalling the app and reinstalling, but I’m going to wait until I’m on-site so I don’t lose the livestream on this and my other cams.

For clarification, it’s only the AI notifications I’m not receiving, because the actual toggle inside the app will not turn on (whether it was on or already off). It simply returns a “bad request” error. The camera otherwise functions normally. Here’s a screenshot of the error before I’d turned all the toggles off.

Note: regardless which toggle I attempt to turn on, the error references “Face Recognition.” Not sure why that is.

1 Like

Will be interested on what you find out. So you use Verizon? You mentioned ONT.

I removed the FiOS router and put my own in and have gotten better performance. Plus, it allowed me to control my network better. Just an FYI

1 Like

No, I’m connected to a relatively small ISP in a remote rural area, and they deployed FTTH a few years back. The WAN issue is one I’ve dealt with for about 6 months since my ISP made some configuration change to its ONTs that affected my ASUS router’s ability to resolve re-issuance of DHCP addresses after a power outage (and some ‘big’ brown outs). Of course its techs won’t give me enough details of those changes to shed some light on my end, so I’m running a jffs script on my router that is supposed to address the error condition, and while it works most of the time as it should, it doesn’t always for whatever still-unknown reason.

In any event, I just got off the phone with my ISP, during which the tech told me he was seeing a Wyze MAC address, not my router’s MAC. Subsequent attempts to re-provision the line during the call changed nothing. It’s like my router has turned into or is being seen as if it’s a hub or some passs-through port (did my router fail at Layer 2?). As it stands, I’m dead in the water trying to resolve the error in my app until I can get home, and see what’s going on with my router/LAN.

1 Like

UPDATE: Just out of curiosity I decided to use my Wyze webview page to see if it can see the camera in question, and it can! Apparently my ISP sees the camera and assigns it an IP like it normally would with my router.

Interesting, I use FiOS and they provided me with an ONT as well. Fiber Gigabit Network. :slight_smile:

I use the ASUS ZenWiFi AX (XT8), love this router.

Do you have a Wyze Cam Outdoor? If so, can you disconnect it to see if the issue resolves? you may need to reboot the router after doing that.

Also, did they provide the Mac Address so you can potentially turn it off and see if it clears things up?

1 Like

Do you have the Ticket Number for the Log you submitted? If you do, can you provide it here as well?

1 Like

I have an RT-N66U, and while it’s a bit dated, it does continue to serve my wifi and routing needs. This ongoing WAN connectivity issue may force me to upgrade if this MAC address issue also persists, but I’m OK with that if forced.

I only have V3s, and I feel a bit embarrassed that I didn’t ask the tech what MAC address he was seeing. Rgardless, I can access my Cam+ cam via Wyze’s webview, but I don’t know if it is the same cam that was assigned the WAN IP, or if it was one of the other two without Cam+/no webview access. Then again, come to think about it, I’m pretty confident none of the V3s have the capability to assign DHCP and/or route such that I could see my Cam+ cam if it weren’t the one assigned the WAN IP. Either way, all I can do is view the cam, nothing else. I might get somewhere if I could telnet into the camera!

In any event, since one of my cams has been assigned a WAN IP, I don’t have access to my router. Subsequently, I don’t have access to my router to block the offending MAC address, but I’m pretty clear this latest issue will disappear once I can shut off the cam(s) or block MAC addresses.

Regarding the ticket number, it’s in my original post.

I would agree which is why I asked about the WCO. In the past there were reports of its base station acting as a DHCP, which was corrected.

Depending on how many camera’s you have, you may want to start one at a time and turn it off, then see if things clear up. You may have to reboot the router each time, not sure though. If problem still exists, then turn it back on and check the next, and so on until you find the offending camera.

Do you have the Ticket number from Wyze? or only the Log listed above?

1 Like

Interesting about the WCO’s.

I have three V3s, and only the one has Cam+. Given you’ve - more or less - confirmed there are no DHCP capabilities built into this model cam, I’m pretty certain the problem cam is in fact the one I can see via webview, But yes, being a former Sr. Network Engineer and fairly well adept at troubleshooting, I would have done as you suggested by approaching the problem one cam at a time, but thanks nonetheless. :slight_smile:

I only have the Log ID above which I received via the app. I then logged into my account on the web, and submitted it (the Log ID) to support. No Ticket# was provided, so perhaps I’ve not completed a step?

I will see if I can get the Log looked at. I was thinking, Can you go to the Device Settings of each v3 and see what IP’s are assigned to them.

See which one has a different IP / Wan address and that should be the one we could focus on.


Hi fletcher969. Thank you for posting the issue here. For the V3 AI detection toggle issue, could you try to update that app to the latest 2.28 version and test if the issue still exists? Thanks.

1 Like

This just keeps getting weirder. I now have access to all three of my cams via the app, and each is assigned an appropriate private IP which means my router situation has resolved itself after nearly 24 hours. I’m assuming when I saw it via webview it was already resolved.

As it was during the ‘blackout,’ I was unable to access my router nor any of my cams or their settings via the app (tried accessing the settings for [Mod Edit] and giggles). I’m going to access my router, and see if I can see anything in its logs.

MOD NOTE: Post edited to conform to the Community Guidelines.

I would monitor. I also got Wyze involved as you can see from the input from @WyzeBaohua . I would still follow what they are suggesting and monitor it as well.

This is bizzare


Hi, and thanks for joining in. I checked my Play Store notifications this morning specifically looking for a Wyze update, but one wasn’t available; however, I just checked again, saw there was an update, and installed it. The toggle issue persists, so I’ll reboot my phone, and troubleshoot this to death until it’s fixed or it persists. I’ll update you accordingly.



1 Like

Just checked the OS version requirement for our Wyze App. Currently, our App only supports Android 9 or newer OS version. From the log you provided, I saw you are using Android 8. Could you update the Android OS version or find another Android device to test it again? Thanks!

1 Like

The AI toggles are turning on and off now. Whether or not the push notifications associated with the selected toggles actually notify me has yet to be determined, but it’s a step in the right direction.

Anyway, after I installed 2.28 (102), I basically tried every setting combination imaginable inside the app coupled with restarting app and rebooting phone, but the error persisted. I took my dog for a long walk, came back in, and remembered spamoni4’s suggestion to sign-out/in from the app…something in all my previous troubleshooting I hadn’t even considered (except that I would have tried reinstalling the app if I were on-site with the cams). Well, either my dog walk did the trick or signing out/in did, because the toggles worked as soon as I signed back in. I’ve re-enabled all other settings the way they were, and the toggles are still working.

I’ll definitely keep the sign-out/in step in mind next time I’m troubleshooting a Wyze app or cam issue.

That said, I wasn’t aware I was outside the OS requirement, don’t recall having read same in a changelog (could have been missed), and I checked throughout the Play Store listing on my phone, and it’s either well obfuscated, or it isn’t indicated thereon. On my laptop, however, Play Store listing indicates the app will work on Android 7.0 and up. Nevertheless, I’m gonna stick with Android 8 as I would lose two key-for-me features I use daily that have no bootloader/rooted workarounds (features quite frankly that are in no way related to users’ interaction with the OS itself…protecting us from ourselves I suppose). I’ll keep the OS requirement in mind if I run into future issues, but it would be helpful if users were aware what might be negatively impacted if the OS version is inadequate, and would negatively impact operational features. One like myself then would have to consider future purchases of Wyze products (I’m not being contentious, just saying from an informed consumer standpoint).

Anyway, thanks for your input!