v2 firmware released to Beta!

Hi, we released firmware to Beta today. Comparing to the, it only changed image quality, no coding change. We believe we restored more details than the previous version and removed some blurry image off center.


If possible, please help us test different scenarios with your camera. If you see issue, the best will be posting v1, v2, and a phone picture. Your help is greatly appreciated! :slight_smile:


If you want to revert f/w version, you can find previous f/w at https://www.wyzecam.com/forums/topic/flashing-your-wyzecam-v2-firmware/.


Known issue:

  • In indoor low light situation, it has a little bit lime green/light blue in images. We are trying to adjust it.

Wyze Cam v2 – Firmware – Software 1.3.107; Android 6.0.1

Image still stutters on moving object (car in motion).

Image latency is now present (approx 5 second delay). Sync time function does not fix the problem.

Camera freezes/disconnects intermittently and app must be restarted.

**These problems do not occur with v1 – Firmware is kind of purple for me in this environment while looks more natural. See attachments.

Thanks! :slight_smile:

I tried on my other v2 cams and so far it seems to be an upgrade to the color accuracy to all of them.

Thank you all! From various channels we see being better than for image quality. Nothing else changed between 1.34 and 1.42. The choppy connection should be the same for 1.34 and 1.42. Releasing to public now! :slight_smile:

This update made my colors a lot worse. I just installed on one camera. :frowning:

I agree! This is happening to me too.

Can you give samples of what you’re talking about? - The colors seem great and natural. - The colors are showing very red.

Weird. For me it was the exact opposite on all three of my cameras. The red/purple tint was on the older firmware. The more natural look for me was on the newer beta firmware.

Your case is the first that I heard of getting worse. If it keeps that way, we will for sure take a replace for it. Can you do following two things:

  1. Cycle through the night vision settings Auto -> on -> off at least one cycle. Do you hear two clicking sound for each cycle?
  2. Fully extend your base and then try to cycle through the night vision settings. Then see if it makes a difference.
Sorry about that!

Just did an experiment. Put V1 and V2 at the same location.

We can see V2 is out of focus except for very close distance while V1 showing much sharper picture for the same area.

Put the second V2 cam at the location. It turns out the second V2 cam focus is much better than the 1st V2.

I have opened a ticket to request an exchange for the 1st V2 cam which is out of focus and defective.

Hope my other 11 V2 cams won’t have this out of focus problem.

v2 is 15FPS which requires faster network. If you see video every 2 seconds for v2 unit, it is likely network related. Can you try SD or turn on night vision temporarily and see if that becomes less choppy? That will tell if it is network related (SD and night vision usually requires less bitrate).

Another question is - do you have the same issue if you are under a same network with your camera?

I have noticed I am experiencing the repeated on / off of the IR LED / Night Mode on my two new cameras. I hear the clicking and see the image going back and forth. I have only noticed this so far at times when the lighting is dusk / dawn and it is getting darker or brighter. Perhaps the sensor is too sensitive to changes and it can’t make up its mind? I don’t have an SD card in either of these yet since I just got them but I will swap around my SD Cards and put one in them so I can forward the video clips next time I notice it.

Can you extend the foot of the stand and see if that still happens? The stand has a strong magnet that seems to be affecting camera in some situations.

I have tried using the SD for the past couple of hours. The problems previously identified still persist. The v2 camera is replacing a v1 camera that was used in the same location without any issues. *I have 3 cameras and have switched them all to SD. All cameras have SD cards. I have deactivated the motion tagging in the v2.

All cameras are on the same network and cellphone are on the 2.4 network. The 2.4 is utilized by the cellphone and smart appliances (WeMO and Wyze Cam) only. Streaming devices are on the 5.0 network.

*Approximately every two minutes the v2 will freeze for 8-15 seconds and then continue. Could this be a cache issue?

I have attached speedtest results and router being used Netgear Nighthawk 2350 (7500v2). I don’t think it is a bandwidth or network issue.

Thank you for your assistance



Having an issue upgrading from to 42. App (iOS) suggests the upgrade, I say yes, it goes through the entire process, then shows me the screen to upgrade again. Like it downloads it, but doesn’t install it. I was able to get my other v2 to take the upgrade no problem.

Hi Sean, yours is the second report on this issue. We are actively investigating with the first customer. If we need your help for info gathering we will let you know. Thanks!