Use an audio codec supported by more media players

Can you please have the audio for mp4 files that are written to the memory card be more universally supported by media players? With the current audio codec used one must use ONE specific player (VLC Player) when there are tons of perfectly good codecs and players already in widespread use is a pain.


Out of curiosity what media players have you tried? I just ran through 4 Windows media players and 3 Mac ones. They all worked just fine.

Make sure that your computer has the proper codecs installed.

Windows Media Player, Windows Movies & TV

So that’s interesting… before posting this, I found numerous forum posts and even a support article on Wyze’s support page that state that the codec used is 8 bit a-law G. 711 and that VLC is required to get audio when viewing the mp4 files on a PC.

E.g., this support article from Wyze from only one month ago states that Windows built-in media players don’t include the right codec, and to use VLC:

I have the k-lite mega codec pack already installed, which includes AAC codecs, so something’s amiss here. Specifically, I’m referring to the mp4 files saved by Wyze Cam v2 to the micro-SD card in the camera - taking these and trying to play them directly on a PC from the memory card. Does that change everyone’s responses? Or is AAC still the codec and I’m encountering an issue that maybe requires me to refresh my codec set / settings?

1 Like

I just pulled a SD card to see what audio format was used there, and it’s A-Law. I just realized I have been seeing AAC because I edit most of the clips I capture clips using iMovie.

So what you are asking is for the A-Law format to be changed. I think that is within the realm of something Wyze might be interested in, as there are so many audio problems at the moment that they may want to change that audio format as part of the cleanup process.

So you have my vote! :+1:

1 Like

@rdumont99 good catch!. its nice to see community members come with a question only to find the answers AND enlighten others. I learned something here that i wouldn’t have even thought to look up on my own. and more than likely this explains some of the difficulties in audio we’ve seen.


We can play recorded events on the device, but not if downloaded or shared with others. The issue is the codec used by Wyze is not natively supported on Andriod, iOS, Mac, PC or Chrome systems/devices. Requiring a 3rd party product, such as VLC, is not an acceptable solution. I tried using Camtasia and heard only a small burst of static then nothing. This needs fixing asap.

Desired solution - Fix the sound codec to be as universally accepted as possible.



That appears to not be the case, or it’s not implemented properly.

I am using a Samsung S9, downloaded a video, and get no sound when playing the video. I don’t appear to be able to attach a screen shot here, but the error message is “Can’t play audio. Audio codec not supported.” Shared the same video to family from the Wyze app - none were able to hear audio. Mix of iOS, Android, Mac and PC, so universal ain’t working.

Only when I played it using VLC player on my PC could the audio be heard.


How did you share? Directly off the card, or by downloading using the Wyze app?

Downloaded directly from app, When played on my phone, no audio. Copied to my computer the d/l file, with no audio until I tried VLC. I also tried sharing from the Wyze app to the family who were not able to hear it, either.

There is no recording on the memory card - seems the advanced, local Storage, setting for Record Events Only did not record to the card. I have changed to Continuous recording and will check it later.

1 Like

So this is audio from a 12-second clip under the Events tab? If you go to Media Information in VLC, what CODEC does it say it is using for stream 1?

PCM ALAW (alaw)


When I used the app to download, it downloaded. After trying to (unsuccessfully) hear the audio using the 'droid app, I copied to my computer and had the same issue with media player. When I shared it from the Event itself, same result.
Is there a way to reset the codec used in the Wyze app?

I used the WYZE app to format the card when I inserted into the camera. Should that have converted the format to the proper one?

I did exactly that: “For 12-second cloud clips under the Events tab, you use the Download or Share buttons.” The result is as I have described - no audio on playback.

I have not removed the SD card from the camera. I downloaded (as described above) and transferred to my computer via USB cable connection from my phone.

Just to verify, I just right now shared a recorded 12 second event to email back to myself. I downloaded and opened in VLC - codec is PCM ALAW. By your description, the system is not recording properly. The share and transmission via email should not have modified the codec, right?

1 Like

Sounds like a bug more than a wishlist item.

1 Like

OMG, apologies. I always watch my clips using the app or VLC, and I just noticed all the clips I have been saying I downloaded from my camera actually went thru iMovie first. So iMovie has been translating them to AAC!

I found some old raw clips on my hard drive, and they are all indeed encoded in ALAW. Me using the app & VLC, plus iMovie for anything I shared, has shielded me from ever seeing the issue.

So very sorry. Yes, this needs to be fixed for sure. Wonder why there are only 3 votes?

@rbruceporter – what apps did you use to test in #2 above? Do you see ALAW too?


Thanks for the confirmation and verification! This does need addressing.


I got bitten by the same bug, since I play and download everything via my Mac first they quietly converted to AAC first. So while I thought I was testing the raw files I was not.

1 Like

I just noticed the same issue on Android Galaxy S9. The audio in general from the camera isn’t great but to not be able to easily export and play it seems like a big flaw.

1 Like