Unbricking Wyze Contact Sensor - pcb reset pin

Carver,

If in fact the hub was in large part responsible for many users ending up with bricked sensors would you say that Wyze would have any responsibility to either replace them or perhaps discount the version two sensors in the same number that the customers lost like if I lost 10 they would discount ten to me .

It would be a great way to soothe ruffled feathers.

Something like that would be in my estimation a good thing

I had a number of the V1 Contact Sensors “Brown Out” or “Brick” when the battery depleted in the past.

I still have 5 V1 contact sensors in service connected to the Wyze Sense Hub. Recently I did take my eye off of one and noticed it was offline for 3 weeks. I thought, well, I just lost that sensor.

I do have an abundance of replacement batteries at the ready so I went ahead and replaced the battery just to see, not expecting the sensor to reconnect. To my surprise, the V1 sensor reconnected back to the Wyze Sense hub and is operating as normal.

There could be some plausibility to your theory, but I have just the one instance to share. However, I do have V2 contact sensors on stand-by if not.

2 Likes

Carver I really like your analysis and theory. It even gives me some hope for doing a V1 setup with the special power/data split cable I bought long ago, where the bridge can be powered separately from its data connection to the camera. (I never used it or my V1 kit.). If your theory holds true, then the more stable separate power MIGHT help prevent low battery sensor failure too?

2 Likes

Yes, I share your optimism for that idea. I do think the low power coming from the camera to the bridge made it hard to have a good, strong stable connection. Others who use that chip were often using another type of Hub to connect those chips to. Even using the bridge for Home Assistant connected through a laptop seems to have had few brownout reports from people. I think the issue is that the power going out from the camera is pretty low (hence why you can’t daisy chain very many V2’s together before the power is too weak and they all start to have issues). So yes, I think if you can power it separately from it’s data connection that it should make it better. It makes a lot of logical sense, and it seems that when people do that for Home Assistant or other companies using the chip have a separate hub, or when these are on Wyze’s new HMS hub, they seem to recover more often (turn back on as normal after a new battery is put in). After reading the TI description, it makes a lot of sense. I fully accept I could be wrong, but it seems like a reasonable explanation, and your solution sounds like a really solid idea. You’ll have to keep me updated on what you find if you try it (if your connection and stability seem vastly improved as we expect).

2 Likes

I’m not sure I am qualified to make complete conclusion on what I think such a response SHOULD be, and no matter what answer I give, others will disagree or want something different. I can see valid arguments from multiple points of view on this issue. A proper reaction will be fairly subjective.

Having said that, there have been people in the forum who said they were offered by Wyze support something very similar to what you suggested…credit toward the purchase of replacements to the new version should they choose to upgrade. I am guessing that was offered to people who were still under warranty for the V1’s, but I can give a hearsay report anyway. If I talked to someone who 10 non-functioning sensors I would first recommend they contact Support and ask if they have any discretionary options available to them. If they don’t, I would then suggest they read this thread since many people have figured out that there is a $5 solution to fix sensors, which is a great deal. If it is too complicated for them, I would suggest asking an electronically inclined acquaintance if they could help do it. If they don’t want to do that, I would recommend they try to sell the brown-out sensors to someone, either someone who is willing to fix them themselves or someone who uses Home Assistant and would just use them there. That way the person would get some of their money back to put into new sensors (whether V2 sensors or another brand or whatever they are looking for).

Having said that, if I were Wyze, I would consider offering customers partial store credit for returned V1 sensors that had a brownout. I don’t know how much they should offer or for how long. That’s supposed to be what a warranty is for in general…a computer manufacturer couldn’t promise a full original refund for any of their computers that wear out over time for the lifetime of the computer for example, but most have a reasonable warranty period where they will replace it. After that, the owner needs to figure out other options. Other electronics are similar. Wyze would have to be able to verify if this is the original owner and if they bought them through Wyze, and how long ago they were originally activated. A partial store credit for their return could be reasonable, except that the postage would cost more than it’s worth, so it’s not worth doing that, but if they don’t make them return it, then people could be fraudulent about it…though they could blacklist that sensor, people could just sell them to a home assistant user after they get the credit. There is a lot of potential for a company with low profit margins to get screwed over badly in a game like this. HOWEVER, offering store credit also gives potential for them to get ongoing revenue from the user who may then buy their V2 sensor system, so in the long run it could pay off for the company profit wise, also give them good PR for exchanging the bad sensors, etc. So yeah, it definitely warrants consideration. Someone would have to run the numbers and figure out how to limit the fraud potential for it, but your idea does have merit and potential to be a win-win for both the customers and the company. But again, it’s a complex answer and they’d need to run some estimates to make sure it’s feasible, and where to draw the lines. Do you refund for a sensor that worked for 4 years before dying out naturally? OR just those under warranty, or where do they draw the line? How to make sure they aren’t being ripped off and lied to? Those are all things that would have to be figured out.

Here’s the remarkably short thread where I found out about the special cable. I fished it out now hoping that we could simply ask other people who’d tried, but this seems more niche than I thought.

Your anecdotal evidence on the lack of Home Assistant PC-powered Wyze bridge sensor failures still seems compelling.

(This arose in context of bridge stability, not avoiding low battery death, so your new theory lends a whole new facet to the tableau.)

Edit:

The linked, even older thread does have more participation.

2 Likes

So is there a solution or not? Can you fix a defunct V1 Contact sensor? Did any of you test the original pretense?

as in the flash programmer :slight_smile: as that looks to be for windows only

cant see the app for macs listed anywhere?

there is no cable that can fix “bricked” v1 contact sensors. the usb cable idea is for those using Home Assistant instead of the Wyze app. Home Assistant can talk to “bricked” Wyze contact sensors without issues (they arent quite “bricked”, see below). its only the Wyze App that refuses to talk to them. If you are interested John, please vote for amending the Wyze App to likewise be able to interface with “bricked” sensors.

to fix contact sensors for use with the Wyze App, you need to buy a TI programmer card, or equivalent
(ppl here in this thread mention a number of alternatives)

2 Likes

Even though it took a while to get through your response, I do like what you said. Fraudulent requests for replacement items or for refund will always exist as long as there are people.

I don’t know the answer but I put the suggestion out there as a way for Wyze to have more good PR

After all I think we can all agree that there’s enough bad PR to last a lifetime

There obviously is a workable solution the problem, is getting Wyze to adapt to it

No, talking about different and related things. I’m talking about using a split cable to provide steady power to the bridge while its data lines are still connected traditionally to the back of a V2 camera.

Seems like this is something WYZE engineers should have implemented.

I can also verify that the M1-based Mac works with the IOS app.

1 Like

to prevent the bricking from happening in the first place, please
vote for low battery email / IFTTT alert thanks

1 Like

I posted a reply in Wyze app to send low battery email / IFTTT for Wyze sensors (v1 & v2)

This comes thru the app months before issues. :slight_smile:

I put Buzzkill on my phone and set up a rule that if any notification from the Wyze app has the word “battery” in the notification, don’t allow the notification to be swiped away. Then it pins the notification for me and I have to tap a “Dismiss” link which ensures I never accidentally miss a Battery notification.

1 Like

carver, are you talking about Wyze lock battery notifications? As I have never got a wyze V1 sensor low battery notification in android. This is corroborated by greymoment in this weekends post;