Unable to update V2 cams remotely

For some reason, I’m unable to update the V2 cams via ios or android Wyze app. I would get a prompt saying a fw is available, hit update, I would see a progress bar go up to around 60% then go back to the begin firmware update page again. I’m aware about the force manual update but it’s really a hassle for where the cams are installed. Anyone know what could be wrong?

Welcome to the community, @fredzlah. Sometimes the firmware updates take longer than the app indicates, and it will timeout in the app. However, many times the devices will continue updating long past what is indicated on the screen. I would recommend force closing the app, and then connect to each individual device to see if the update actually failed.


I agree try upgrading each individually. Start by live viewing, then clicking the gear then “device info”. At the bottom is the upgrade or check firmware link


I had this issue. It said update failed. I closed the app went back in and it was updated

Same here. Said update failed during batch update but cam was actually updated on next check.

Tried multiple times, closing app and relaunching, still doesn’t look like it updated

Still no luck. I see the progress bar and around 50%+ it will return back to the screen asking to update.

I’ve also tried restarting the cameras physically and through the app.

Your post topic says’ update remotely’. Are you trying to update while on the same wifi as the cams or are you accessing thru cellular?

1 Like

Initially I was cellular but during troubleshooting I also did WiFi within same network.

Not to be repetitive but you tried to update each cam individually as @Omgitstony suggested?

1 Like

It’s ok. Yeah I’ve tried individually.

The only method that works for me is manually updating them via SD card. Just a big hassle for me since I have to use a ladder to reach the cameras.

As an observation. I noticed right when I select update, around 1-5% on the progress bar I hear a click and the camera restarts with a amber light, blinks amber then to a solid blue light

I’m not sure what to suggest, but I’m thinking it’s a connectivity issue, since you can manually update but not remotely. Could be an issue in your WiFi - have you had any problems with viewing our cams dropping connection?
If not you should probably Request Wyze Support Help Here. They have tools that can remotely analyze your WiFi and certainly more knowledge than I do.

1 Like

None at all. I’ve had no problems at all connecting to the cams and viewing them live for a good amount of mins. Never seen them drop connection.

I’ll submit a ticket about it.

Thanks so much for the help.