Unable to download any events

Same issue all cameras , was working when previously used a couple months ago. The Loading label appears and just spins. Trying to download video from cloud / not using SD card.

Welcome to the Wyze User Community Forum @davempa1 :raising_hand_man:

I just checked my V3Pro Video Events. A 24s event was downloaded to my system gallery in about 7 or 8 seconds. It gave me the momentary banner confirmation at the bottom.

What app version are you currently using and on what device? Do you have another device to test this on? What is your ISP download speed?

I saw another complaint of this, but am not able to reproduce. I will keep an eye on reports.

Thanks for reply

Wyze App 2.38.4.(3)
iPhone 11
iOS 16,2
Downloads consistently over 700

Checked on my wife’s phone same device and IOS as mine, same result just stuck in loading .

We have no other issues seeing live or reviewing events, just downloading

I am on Android and can’t duplicate this either.

Can you try on a different network? Cellular data is fine, or another wifi network.

same problem for me, just spins, if you try downloading like 3 times it eventually goes kinda hangs the app and video later shows up in your phone gallery

What app version are you on? Can you get an app log (account > Wyze support) and contact Wyze support, give them your log id, and explain the problem. They should be able to pass it up to the correct team

I am having the same issue. Does anyone know how to resolve this ?

same issue here on iPhone 8. Firmware, app 2.41.5 (5). Just says LOADING and spins. Been happening for weeks. Need to copy some of these to my phone. and can’t.

Any update on this? I’m having exactly this issue with my iPhone/iPad. Very frustrating! I’ve updated the firmware, still no luck.

App version 2.43.5(3)

I use iOS app 2.43.5 (3), iOS 16.5.1 (c), v3 Pro firmware and have no issues downloading events to my iPhone SE2020 or 4th Generation iPad 12.9.

1 Like

Same issue with me on both iPhone and iPad. iOS is at the highest level available, Wyze client is the newest available. Camera firmware is at the highest level. I’m at home on a 1Gb broadband with excellent wi-fi response. Storage space available on both devices. I logged in and typed this while I’m watching the “Loading…” loop infinitely. The only other weird thing I can see is that on the playback from the SD card, I can see the green bar showing the recording at that time but I can’t play it back; it says “No replay of video in the current period” despite the indicator line being solidly in the middle of a marked recording period.

What app and firmware are you currently using?

You say at the highest level, but there are many glitches that we have run into over years between app stores offering the wrong version or a later version being out and just not pushed fully out yet because of delays with stores (I’m taking to you Google!) :slight_smile:

And if this is an issue we run into numerous times with a certain version of either app or firmware it’s something we might be able to get flagged to the engineers and make it a known problem

iOS 2.46.1 (4)

Same problem here, have had it for months.

Is this ever going to be fixed?

1 Like

Are you using a V3 Pro? What happens if you try to download a video from the Events page? I just downloaded this from an event video from this morning.

This seems to have been fixed over a month ago with resets and updates. All set now I think.


Unfortunately, this is still occurring for me. For the other commenters who wanted the laundry list of levels and for those who still have the problem, please see the following:

I’m using a Wyze Cam V3, firmware, Wyze App, IpadOS 16.7.1, iPad 7th gen 32Gb. Tonight I cleared the app cache, synced the time with the camera, restarted the camera, put in a new SD card, formatted it, and resynced the time and restarted again and still had the problem. Please note that the endless loop problem happens when trying to download the short event videos from the Wyze events list (usually after watching them). In contrast, I can record from playback and these videos save to my Photos just fine when I push “stop”. Therefore the issue is between the Wyze site events recordings and the app.
SIGNIFICANT UPDATE: I tried to download the same video about a dozen times in rapid succession and it actually downloaded twice in a row (and then failed the next 5 times). So the problem is actually intermittent, but consistent enough that I have thought for months that it was a 100% problem.
My latest guess is that my network might be slow and if the Wyze site encounters a delay when establishing the start of the download, it fails and goes into an eternal loop. I will see if I can set up some way to test this but I’ve spent far too much time already on something that should just work. I hate debugging products for manufacturers now that I’ve retired from my job which involved a lot of that.
UPDATE Nov 3, 2023: I accessed my router’s control panel and turned off the connections for all the 30 wifi and wired devices in my household other than my iPad that I use for Wyze. The problem still occurs.
To eliminate the iPad as a potential cause, I set up the Wyze app (new install) on my iPhone SE running IOS 16.6 and it also has the problem (1 successful download out of 10 attempts so far). I disconnected this iPhone from my wifi and tried to download over LTE cellular, and it still has the problem. So I believe I have effectively ruled out my devices and internal network. (Speed tested at Ping 17, download 268 Mbps, upload 105 Mbps)
So the problem is with the app, the internet, or Wyze’s website that manages the Events downloading.

How slow is your network and have you done a speed test on it?
My 2.4GHz network download speed is 92Mbps this morning and the 5.0 GHz network is 546Mbps. I download three event videos this morning without issue from a Version one WCO, a V3 cam and a V3 Pro cam.