Event playback stuck at 5mb - never downloads

This is a major problem that I noticed only a few days ago. When I play back a recorded event, it gets stuck at around 5mb, then spins forever. This is new to me and makes the cameras mostly useless.

One trick I read was to swipe to the next event then swipe back. This sorta works but not consistent.

What is consistent is getting a notification that there’s an event, and I can see all of 1.5 seconds of it before it stops downloading and spins to eternity. This happens on both my iPhone 8 and iPhone 12.

These are v2, but I don’t see how it matters, since the problem is between the recording server and the iPhone.

Any fixes for this?


Same Issue here… With Wyze Cam Pan ver and Wyze Cam Outdoor ver
IOS WYZE app ver 2.18.23 on iPhone 12 ver 14.4.1

This is happening on my v2.

V3 and Pan seem to work with no problem.

Did you ever get it resolved?

I contacted support, who wanted me to reset all my cameras, which takes about an hour, so I hung up and did it later. At first, it seemed to fix the problem, but today, the problem is back.

I see all the RECENT EVENTS, and when I click one to view, it downloads anywhere between 4MB and 10MB and only plays the few 2 or 3 seconds - when I’m LUCKY. The latest problem is that it shows that it downloads, but then doesn’t play even the first second - it’s just stuck.

I’ll be on the phone again with Support today. I hope they don’t want me to reset all my cameras again.


I have been having this same problem for about 6 weeks now. V2 only, my V3 cams playback events just fine.

I reported this through the app’s reporting feature but no fixes yet. This seems like a MAJOR bug. Several people I know are having the same issue.

(Work around: download the event to local does seem to work, but this is ridiculous)

I gave up on Support after waiting on hold for 30min today. While I waited, I found many others with the same/similar issue.

This morning, I kept trying to view the same event about a dozen times, and eventually it DID download and I was able to view it. But then I tried again, and it got stuck. It seems to be a problem with the download server, but there’s no way for me to troubleshoot their problem.

It would be nice if Wyze Support would fix this problem.

It just spins now - Most of our cameras just get hung up on buffering.

Are the Wyze camera servers FULL? - When I’ve received a Notification and go to my Events page, it frequently buffers continuously (showing a low download Mb number) or displays an error message window.

When attempting to view event videos I’m getting an error message. “Error code 06 - failed to fetch the video from cloud”.

Events Won’t Play Spinning Wheel

Freeze on video events - If I click on a recent video event usually all I get is 1 second of the video then the feed freezes and I get this twirling circle with some megabit readout making the request a total failure

It all sounds familiar. I have two V3 cameras (both with Cam Plus) aimed at the same location from different angles, so if one triggers the other should too, RIGHT??? WRONG!!!. 70% of the time, both will be triggered simultaneously - BUT - I will often get a Notification and Event from one, but not the other. This could be from either camera; no rhyme or reason. Also, my two V2 cameras in a separate location (each also aimed at the same area from different angles) do the same thing about half the time. When I KNOW that the second camera should trigger whenever the first one does, but DOESN’T, it’s another irritating reminder. I feel stupid being thankful when they actually work right. It’s an “over-promise and under-deliver” syndrome. Shame!

This is still a problem.

I’d say about 70 percent of the “12 second” videos are between zero seconds and one second.
I noticed today that Wyze is offering a service for longer videos. I won’t bother, because they can’t even deliver on their 12 second videos - why would I pay extra for videos that may or may not play?

Wyze support responds to my situation like they’ve never heard of it before, even though I can see that it’s an ongoing problem with many of their customers.


I am having the same problem. Spinning wheel does not load, stuck at buffering. There is no point to having these camera if they can’t properly record videos.

I have two v2 cameras with SD card and both have the similar issues since a few months. ​When I tried to play a recorded event, the player get stuck . If I press the playback button then I can see the footage. If I remember correctly this behavior started after a software update, like if it was done on purpose to sell their hosting service maybe? Some comments on this forum speak about server problems but if we use a SD card the 12 sec footage is save locally and has nothing to do with wyze servers no?

When you press the playback button, you’re playing from the SD card, always 1 min minimum, the 12 secs versions from Events button come from their servers.

Are you sure about that? Is the camera recording events even if you don’t have a sd card? Because if it is the case, then you are probably right. But if it’s not, then it must be recorded locally no? An other test would be to cut the internet on your wifi network and see if you still have access to the 12 sec recorded even.

Pretty easy to tell if you have a camera w/o SD card, the 12-sec clips on the Events page will play with or w/o SD but on the one w/o SD if you hit the Playback button it’ll say “no SD card”. The camera default is to record 12-sec clip to the cloud with 5-min timeout, if you have SD card you can either do continuous recording or events recording only.