Random Wyze Cam V3 recorded videos won’t download to photos on iPhone

I’ve tried everything that has been suggested to fix my problem and nothing has solved my problem. Not always, it’s random, but most of the time when I try to download a recorded event to my iPhone photo library. I get a message “loading” and the attempted download of the video to my phone never finishes. It’s stuck on the “loading” message. I’ve found a bunch of solutions on here that worked for others, but not for me. I’m out of ideas. I tried reinstalling firmware. Clearing cache. Turning sound on. Turning sound off. I tried logging in and logging out of the Cam Plus app. I tried unplugging the camera and rebooting. I gave the Wyze app access to all photos on my iPhone. This problem began several months ago. I can’t even find a workaround, except go to record mode on my iPhone and save and edit the video using an iPhone playback of the Wyze Cam V3 video. Help! This started happening several months ago. It’s so frustrating and I’m a former computer IT guy debugging and fixing and coding and supporting hundreds of end users on multiple platforms and devices.