Unable to connect cameras

If you have a step that I haven’t tried let me know: Cam V3

Had camera connected for a year or so then all of a sudden not connected at office/work.
Here is what I’ve done to try and reconnect:
Disabled 5G on the SSID I’m connecting to. Using iPhone let it scan QR code and afer 15 or so seconds camera says connection timeout, rescan qr code. I can see the camera connect and get an IP address on my network.
Next I verified most recent app on iPhone. Rebooted iPhone, reset camera, power cycled camera. Made password more simple.

Then took camera home. On home netowork same results, connection timeout then says to rescan qr code.
Steps:
Tried all three of my SSID’s all with 5G disabled. Then changed security on router to Open, still same results. WiFi is 2.4G, 20mhz channel width, channel used is not busy. Access Point within 8 feet. My home has tested to 990mb download and 150mb upload. Again, I can see it connect for a 15 or so seconds.

Okay getting frustrated, threw camera in trash and remembered I had a brand new Wyze Cam V3 in box and never opened. Opened it and started over here at home same results on home network. Have video of me opening brand new camera ( I’ve had it for several months or so but still in sealed box)

Okay next I hookup a TP-Link basic WiFi router. Same results, communication terminated, rescan qr code. Now using the new camera
Steps:
Tried iPhone, iPad and then an Android tablet using the Wyze app, same results.
Canged TP-Link security to WPA and not WPA2 same results. Made sure connected to 2Ghz SSID. Other things I’ve done: Forget network on devices and tried again. Reset cameras by pressing and holding down the button until you see the reset lights. Power cycled routers, Acccess Points/routers (three different ones/brands) Tried iPad, iPhone, Android tablet. Location services enabled on all devices, App has access to local network in app settings. Work and Home is using multiple Ubiquiti Access points behind different routers. Home Arista firewall and at work SonicWall. Then the more basic TP-Link WiFi router.

I’ve installed Next, Arlo, Hikvision, Alarm.com and a few others and as a 25+ year network professional I’ve never had a camera I couldn’t get connected.

That is until Wyze.

You can see from network information the cam connects long enought to get an IP address.

I have the exact same problem, Wyze v3 been working well for over two years. A few days ago i did a firmware update and they all worked, Yesterday i noticed 1 of them did not work anymore although its connected to the network. Tried swopping power supply to one where anther camera is working, Removed SD card, And finally tried to re-setup, but the connection just times out! Reading al the threads online, there seems to be no comment from Wyse to an actual solution to the problem?

I just tried to set it up from another device and it worked no issue. Weird indeed