Unable to add new Wyze Cam Pan v2 to existing Unlimited Cam Plus subscription

I have an Unlimited Cam Plus subscription with about 15 cameras on it. I just purchased 2 new Wyze Cam Pan v2 and set them both up. When I go to Services->Cam Plus->Add New Cameras, I see one of them listed, but not the other. I checked Services->Cam Plus Lite->Add New Cameras, and I see the second camera there (but I did not enroll it in Cam Plus Lite). I confirmed that both cameras are on the same version of the latest firmware

I tried doing a factory reset on the camera and signing out of (and back into) the Wyze App on my phone (Android). Still same problem.

I just sent a request into Wyze Support, but I am wondering if anyone else out there has a suggestion.

Thanks in advance for any help you can provide!

  • Rob

Welcome to the Wyze User Community Forum @asterrob.leitner! :raising_hand_man:

For the cam that is showing when you click Add Cameras In the Cam Plus tab, I am assuming this one was successfully assigned to Cam Plus by clicking the box.

Oddly, any cam assigned to Cam Plus Lite is also supposed to show up as an available cam in the Cam Plus List. Is it showing as assigned in CPL or just available to be assigned?

Did you do a cache clear before you signed out of the app, closed it, and restarted the device and power cycled the cams?

Yes, the camera that did show when I clicked Add Cameras in the Cam Plus tab was able to be successfully assigned to Cam Plus by clicking the box.

For the camera that does NOT show with I clicked Add Cameras in the Cam Plus tab, it DOES show up when I click Add Cameras in the CPL tab (but I did NOT actually add it to CPL).

I hadn’t cleared the cache before, but I did just now. I then signed out of the app, closed it, and restarted my phone. While the phone was restarting, I unplugged the camera. After logging back into my phone, I plugged the camera back in.

Still same problem. The camera shows up when I click Add Cameras on the CPL screen, but not on the CP screen. :frowning:

Wyze Support is proposing to cancel my Unlimited Cam Plus subscription (giving me a prorated refund), and then charging me for a whole new Unlimited Cam Plus Subscription. I asked what the implication of that would be. Would I have a lot to do to setup my devices again under Cam Plus (notification settings, etc), or would it be as simple as just clicking Add Cameras and checking 17 boxes.

I haven’t heard back from them yet.


Yes. But I don’t know that it will solve the problem.

What happens if you delete the cam from the App and reinstall it new? Have you already tried that?

Already tried that. Did factory reset of camera also. :confused:

When you deleted the cam, does it disappear from the available list in the CPL tab before it is reinstalled?

Go ahead and assign the cam to CPL and then see if it appears in the CP available list. Look again after a cache clear, sign out, reboot.

By chance were these reconditioned cams you bought recently?

Not reconditioned. Bought them as NEW directly from Wyze. Though, now that you mention it, the one giving me problems didn’t have the little piece of plastic on the lens when I took it out of the box. Hmmmm…

Just tried adding to CPL. Still doesn’t appear in CP list.:confused:

If it were me, I would make them replace the cam. Something doesn’t pass the sniff test with that one and it shouldn’t take deleting your entire subscription with all your other cams to do it.

Wyze was selling reconditioned cams in their Garage Sale event. Make sure that isn’t what you bought.

Well guess what! I got the camera added to my Unlimited Cam Plus Subscription!

I went to the home screen in the app (I’m using Android) and clicked on the camera. In the top right corner, just to the left of the “Settings” gear icon, is the C+ icon (Cam Plus). I clicked on that, and it asked me if I wanted to add Cam Plus to the camera. I clicked “Apply”, and it was done!

I went back to the Account->Services screen, and the camera was listed under my Cam Plus Unlimited Subscription (now 17 cameras!). YAY!!!


  • Rob

You solved this one all on your own! Make sure to give your last post the green Solution Checkmark!

Thank you also for sharing the solution. I will bookmark your procedure to fix this and keep it in my tool bag for when\if this comes up again! I read nearly a thousand posts a week and this is the first time I have read that particular method of adding a cam to Cam Plus. I learned a thing! :laughing:

Glad to hear that it is now working for you!

1 Like

Good to hear you were able to solve this on your own.

I had the same issue and a new subscription appeared on my services (Single Camera Annual Plan). The only way camera can get to Cam Plus was to add it to this new subscription. I contacted support and that was the solution provided by them.

Interestingly, the plan appears on my phone and can’t be edited because it says it must be managed on the website, but the subscription does not show up on my services account on the website.

I will keep this in my notes to try in the future, as the single camera subscription is supposed to expire on May 12.

Was it a Free Trial Subscription (I think those are 30 days now) that comes with the new cam when you first install it? If that is the case, it will not expire but will auto renew and start billing you monthly unless you cancel it.

If you purchased the subscription direct from the Wyze Website (services.wyze.com) it will be in the list on that page in your account after you log in. Not sure if trials show up before they are converted and start to bill.

If you purchase it from within the app, which is actually purchased from and serviced by the App Store for your device, it will show up in the Subscriptions section of the App Store.

My V3’s are not working on my UCP sub. All my older cams are, but the new ones won’t. All I get is a pic and no notifications. I bought the new ones for the front door and driveway so this is not good. I bought Wyze Cams in their early days so I would NOT have to PAY a SUBSCRIPTION FEE. Any help out there? Thanks! EH

When you installed the new V3 cams, did the app ask you to assign the cam to your existing license by clicking the Activate Now button?

When I install a new cam, during the setup, clicking the Activate Now button automatically assigns it to my Cam Plus Unlimited license. This is the UI I get:

If you click Add Cameras at the bottom of your CPU license in Account → Services, is the new V3 listed there and checked?