Timezone for scheduled rules? Bug/Issue with rules running correctly

Hi all,

I use Wyze products outside of the US in Western Europe. All is mostly fine (apart from severe camera audio/video sync issues), however I’ve encountered an issue with scheduled rules.

All works as expected until I add an IF condition to a rule using a time setting.

E.g “turn off a bulb after 5 minutes” works fine if I don’t set any time conditions but if I create a rule to “turn off a bulb after 5 minutes if between 9pm and 6pm” the rule won’t fire.

I’m unsure if this is a bug or because Wyze is currently US focused.

It occured to me that the timezone for rules might be defaulting to the US and if this is the case, which zone.

If anybody has any insight, it is greatly appreciated. :+1:

Any insight on this Wyze team?:+1:

I experienced this problem randomly at times when I still had my lock loaded in my Wyze account. Rules would fire, even outside of the specified times. Notifications would come through outside of specified times, etc.

Once I removed the lock and sent it back for a refund, my rules have worked flawlessly. Do you have a lock on your account?

Additionally, time constrained rules don’t take effect until it hits the start or end time for the first use of it. So when I set up a rule that when a door opens, turn on a lamp, between 10pm and 6am, it turned the lamp on all day long when the door opened. However, the following day the rules worked only within their specified time constraint.

Thanks for the response.

I don’t have a wyze lock, just cams, bulbs and sensors.

My inkling is that the times used in the scheduled rules codebase are using a US based timezone, not my local/device timezone. It would be great to get confirmation on this from Wyze.

In my example, I’ve rigged up a motion sensor to turn on a light when someone walks up our pathway and then turn the light off after a few minutes. However, the rule doesn’t fire (to turn off the light) when I introduce a ‘between these hours’ timeframe into the rule (to cover the nighttime hours).

Exact same problem here in Texas… created a rule to turn a light on in the kitchen when someone walks by motion sensor. Doesn’t work when adding time to the rule.

Here’s hoping a wyze team member area sees this and can confirm the timezone used or log the bug.

For several months I have used a Schedule Rule to control the ON/OFF cycle of a Group of Plugs and it has always worked but for today. The Rule “Turns On” the Group of Plugs with a “Start Time” of 11:45 PM and an “End Time” of 06:00 AM. The Rule did successfully activate the “Start Time” at 11:45 PM on 22 May 2020, but failed to activate the “End Time” of 06:00 AM on 23 May 2020. Has anyone experienced a similar failure of a Schedule Rule recently? Perhaps Wyze servers failed around 06:00 AM on 23 May?

I’m having to control my light + motion sensor with Alexa Routines until Wyze fixes this problem. There’s a lot of latency this way tho.

I have the same issue. My lights came on at 4:15 am (Eastern Time), however the 7:30 off time did not fire. so something must have happen after 4:15 am. I just ran a few more tests and found that the Scheduled Rules are not working - but the Device Trigger Rules are working fine, even when you set a time frame. I hope this gets fixed soon as I rely on these rules. Plus, I have fully cutover to Wyze from Hubitat today. :slight_smile:

I opened a ticket with Wyze and hope they will respond soon.

It’s a problem I’ve had from the offset (some months now). Adding a time window to the rules seems to stop the triggers from firing.

As it stands, I can’t use the size bulbs for nighttime security as the turn off trigger doesnt fire when I add a time window. Eg turn light off after 2 mins between 10pm-8am

At one time approximately a year ago, Schedule Rules failed when the Start Time and End Time were on different days (e.g., Start at 2300 and End at 0600). That was corrected, I presume, in the Wyze servers that control Schedule Rules. For some time now Schedule Rules that span two adjacent days have been working, until 0600 23 May 2020 for me. My primary Schedule Rule was to turn ON a Plug Group at 2300 and OFF at 0600. The Start time of 2300 worked on 22 May but the End time (0600 the next day) was not executed. But now one day later, this identical Schedule Rule did work as it has in the past, sort of – the Plug Group was turned ON at 2313 instead of 2300, but it did turn the Group OFF at 0600. So, its partially fixed.

In my case, something happened between 0600 22 May 2020 and 0600 23 May that caused a failure. But, as of today, this Schedule Rule appears to work properly.

Here is a temporary solution I implemented. The primary Schedule Rule (ON at 2300, OFF at 0600) is left intact. I added a secondary Schedule Rule that turns the Group ON at 2301 with no End Time, and a tertiary Schedule Rule that turns the Group OFF at 0601, again with no End Time. Yeah, this is very redundant however only temporary; but if any action on the primary Schedule Rule fails (either ON fails or OFF fails, or both ON and OFF fail), then the secondary and tertiary Schedule Rules, which do not span two successive calendar days should/may be effective and provide the intended outcome. By the way, these temporary Schedule Rules can remain programmed in the App but not enabled, effectively putting them on pause without deleting them.

Gwendolyn updated everyone in another forum. Apparently there was a server issue which got resolved this morning around 2am. All of my rules are now working again, even ones which cross over days.

I have a daily rule which turns on notifications at 10pm and triggers all of the lights to go on if motion is detected. At 4:15am the notifications are turned off and the lights go back to a normal schedule.

Here is the Link: Rules failing 5-21-20 - #70 by WyzeGwendolyn

1 Like

I seem to be having problems again related to Device Triggers Rule. I have a motion Sensor which is supposed to turn the lights on Mon - Sunday between the hours of 8pm and 6:30am EST. When I activate the sensor, no lights go on. If I turn the time constraints off, the sensor works as expected. Is anyone else experiencing this?

It’s always been like that for me… I gave up and use Alexa for scheduling

Got up this morning, added another Motion Sensor and setup a rule and it worked as expected. I then decided to turn the rule back on for the one which is not working and adjusted the time to this morning start – and it is working as well. I moved the new sensor to my garage for now. I reset the start time back to 8pm. will see if it has issues.

But for some reason, the issue seems to have corrected itself.

My actual Schedule seems to be working, it was only with the Device Trigger Rules. I will monitor it more closely.

Can Alexa handle Conditional settings? I am inclined to say no, or might have to integrate IFTTT into it. Curious.


Just posted my latest findings – it still is not working. Thanks for the work around - Alexa works like a champ. So I have that activated as well.

It looks like the issue is only with the motion sensors. Although I have a couple in the house which seems to work.


Ok - so I did my test again and found that it was indeed failing. I responded to the ticket I opened yesterday. But here is what I have determined:

Motion Sensor: When motion is sensed on the Porch Sensor between the hours of 8pm and 6:30 am turn the lights on. When Motion stops during the same period, turn lights off. (THESE 2 RULES DO NOT WORK).

The Motion sensor is working as I do get alerted that motion has been detected and the Wyze app shows motion detected, see attachment. the Rule simply is not firing.

Contact Sensor: When the front door is open during the hours of 8pm and 7:00am turn the lights on. When the door closes during the same period, turn the lights off. (THESE 2 RULES WORK)

A Temporary Solution: What I had to do is use Alexa to perform the same task - which does work for me. However, this is not a solution as I want to utilize the device trigger rules and not a third party solution.

I provided Wyze Support with the following attachments:

Thanks for reporting. I think we had reported in the past in another thread some months ago and they said it had been fixed…

The thing I don’t like about having to use Alexa is the latency. The sensor to light takes longer than it would with just Wyze. But, it is what it is until they fix it.

So, I think I have it working now. Can you try the same thing I did? I already let Wyze know so that they can track where the issue is.

Here is what I did:

  1. Click the Pencil, top right of app, to Edit Rules and Devices. Do not click the plus sign on the main screen of the app top left area
  2. Select Edit Rules
  3. Create your device trigger rule by clicking the plus sign on the rule screen

When I did it this way, it seemed to work without error. Matter of fact, it ran last night.

Hopefully you will experience the same

It seems like it’s working now. Thanks.

I’ll have to wait until tomorrow to be 100% sure since I had two different rules with Alexa that I’m migrating back to Wyze.
One from 7pm to 11:59pm at full brightness when motion sensor detects motion
and the second from 12:00AM to 5AM at 30% brightness. I don’t like the idea of needing to walk in the kitchen after the rest of the house is dark and being blasted with full light.