Trigger Rules with Times not firing 8/28

After the latest outage, I reset my outdoor lights trigger events as follows:

  • When motion is sensed on the porch, turn on the porch and garage lights until it has been cleared for 5 minutes. this rule is set to fire between 8pm and 7am.

  • When motion is sensed on Garage Sensor, turn on the porch and garage lights until it has been cleared for 5 minutes. this rule is set to fire between 8pm and 7am.

  • when the garage Door opens between 8pm and 7am, turn on the garage lights. Then turn them off 5 minutes after door is closed.

  • when the Front Door opens between 8pm and 7am, turn on the Porch lights. Then turn them off 5 minutes after door is closed.

I tested tonight after 8pm and none of the triggers fired. If I were to remove the time constraints, they do fire and come on.

Is anyone else experiencing this as well?

Currently my only option is to leverage Alexa Routines which seem to work fine. However, it is more delayed than I would like. I am also looking at reactivating my Hubitat as I still have some sensors and lights. But would really like this to work in Wyze.

@WyzeGwendolyn, this has happened in the past, can you please provide some assistance on this.


1 Like


I have times set up for my motion sensors.
Don’t have this problem.

Will be interested to find out what’s causing your problems.


Me too. I have timers on the other lights in my home with sensors. those seem to be ok. For some reason it is only with the outdoor ones.

I can operate the lights via the app, and I can operate them via triggers, but only if there is no time associated to it. I even rebuilt the triggers. May try that again. For now, I am using Alexa.

SO I rebult my triggers and decided to change the names of them. I usually reuse the same naming convention I have. Tested with everything set, but made the start time earlier this afternoon and stop time tomorrow morning at 6:30am instead of 7am. The tests were successful. So now I set the start time of the triggers to 8pm. I will verify tonight.

I cannot explain why the test succeeded today and not last night. Maybe it was changing the end time or the name. Maybe Wyze does not clear out the Rule fully when it has been deleted.

who knows.

1 Like

So I did my evening test and even though it worked earlier today, my porch lights are not going on. The only change I made was modifying the start time from 1:30pm to 8:00 pm.

I am not sure why it is not working

1 Like

So I finally seem to get my rules working on my outdoor lighting. I will monitor this tonight and tomorrow. But here is what I discovered and I sent a DM to @WyzeGwendolyn about it:

I think I figured out the issue I have been reporting for a period of time now.

Here is the scenario which it does not work with - remember I am on the East Coast:

  • I have a few triggers set to turn my porch lights on between the hours of 8:00pm and 6:30am. (This stopped working after the last outage).

Here is what I just did to get it to work:

  • Modified the trigger to make sure the start time (ignoring AM/PM) is before the end time. so I set it to 6:00 pm to 6:30 am. and the light came on when expected and off when expected.

I then set it back to 8:00pm and 6:30am and it did not work.

I believe there is an issue within the code that is getting confused with am/pm or ignoring it. This is causing an issue because it looks like the end time it before the start time and therefore the rule does not fire as expected.

This is only speculation on my part for now, hopefully it can be conformed by Wyze.

1 Like

Interesting… hope you get an answer from Wyze


Me Too.

Sorry for my delay! I’ll send this to the team. @spamoni4, could you please recreate the failed firing issue and send in a log? Then please give me that log number.

1 Like

I submitted my logs on 9/2/2020 and received 37751 as the ticket ID.

Hope this helps. However, nothing shows up in the Rules History.

1 Like

Thank you very much!

I’ve been seeing the same issue, but what’s odd is sometimes my rules with times do fire, other times they don’t. I have mine set to start at 8pm and end at 6am.

So we found 2 work arounds which seem to be pretty consistent. I like @Cap solution as it does not require me to adjust outside of the hours I wanted.

Here is what we found and I sent to @WyzeGwendolyn:

@Cap suggested the following to correct the trigger issue: Do not set the start and end time on the hour or half hour. simply add or subtract a minute. For example: My trigger was set for 8pm to 6:30am, simply changing it to 7:59pm and 6:31am actually made it work.

My initial fix the other day was to ensure the end time was after the start time, if you were to ignore the am/pm. Meaning: if you look at the start time of 8pm and end time of 6:30am and then eliminate the am/pm, the system could see that the start time is after the end time by 1.5hours. This would cause the trigger not to fire as it would think there is nothing to do. I simply changed the start time to 6:00 pm and end time to 6:30am and the triggers fired as expected.

1 Like

@WyzeGwendolyn I reported this issue with logs last year. Still no fix.

Thanks, I’ll give this a shot and see how it works. Hopefully this bug is on the team’s radar @WyzeGwendolyn. Sounds like it’s been an issue for a while.

yea - as with @Cap, I reported it. So far no fix or feedback yet

Unfortunately adding or subtracting a minute to the start and end times on the rules didn’t work for me, and I tested on two different cameras that have triggers set up multiple times. None of them fired.

Interestingly, triggers that have start/end time with a motion sensor work very reliably, so it seems like this issue may be specific to camera triggers?

I’ll still give setting the start time to an “earlier” time than the end time (ignoring AM/PM) a shot and report back.

Interesting, my issues were with Motion and contact sensors. When I corrected my issues, I actually deleted the old rule and created it again.

This gets more confusing.

@WyzeGwendolyn This issue seems to be a time zone problem, but only with certain rules. I’m in Mountain time, but my triggers scheduled for 8pm don’t work until 9pm, suggesting it’s using Pacific time. Likewise, they are scheduled to stop at 6am but continue to fire until 7am. This is only for my rules that use cameras as the trigger. Rules using sense devices or bulbs work fine.

I tried recreating the rules but no luck.

1 Like

Thanks for letting me know! I’ll send it over. Any chance you have a recent log I can give the team?