Thermostat wiring help, no AC

I installed my thermostat before winter and it worked fine for heating. It’s warmed up here and the
AC isn’t kicking on. I’m attaching my original thermostat wiring and the wyze wiring that works for heat.

I live in a condo where the building controls when the heat and ac are active, but I confirmed they switched to AC on Monday.

Original wiring

Wyze wiring with working heat but no AC

Without knowing how their system works, I cant be of much help. The old thermostat had both a B and O wire- this usually means that B is the common wire, but they might be doing something weird like connecting your unit to 2 different systems. A normal heatpump is switched from heat to cool mode when the B/O wire is energized/not energized, it’s not something that your building management has any control over.

Ok, the old thermostat had a jumper from Y to W, but I’ve read Wyze doesn’t need jumpers. I can post a picture of the wiring schematic on the heat pump if that would help.

Wyze doesn’t need jumpers. W is used to call for heat on a non-heatpump system, so I’m assuming the jumper was there because that thermostat required it to work on a heatpump.

When you test the A/C, what happens? (Does it blow room temp air, no air, etc)

The AC just blows room temp air.

Have you tried running the test longer?
It might be calling for fan before the compressor actually kicks on and chills the coil down.

I’ll try it again now, but I’ve had it running for several minutes with no apparent change in temp.

Not sure what to tell you. Have you tried hooking up your old thermostat to make sure there’s not a problem with your compressor?

the Wyze it sounds like the compressor kicks on, but it blows warm air. I wired up the old one and it doesn’t seem like the compressor turns on at all, still blows warm air.

It’s an issue with the air conditioner and not the wyze then.

So it is the building controlling the system. You need the building guy to look at your system
You have access to compressor?
Could be fuse blown from the current configuration.

I tried hooking mine up and when it test the heat , it turns on the heat pump and when it tries the ac , it turns the emergency heat on. I finally put my old unit back on

It is definitely not plug and play.

So I have access but its such a pain to get to, it’s in the ceiling above the shower. I was double checking the wiring up there and looks like the O wire is nearly shorted out. Could this be the issue? I’m going to rewire that and give it a shot with the old thermostat again.

Good start but needs a better frontal pic.
So we can read.

I think replacing that wire fixed it, at least I’m getting cold air on the old thermostat. I’m going to let the condo cool down a bit and then switch out the wyze thermostat. :hot_face:

I’m guessing when I was up there the first time that wire was almost shot and messing with it completely shorted it out. From what speadie was saying the O is used to flip the system from heat to ac so that would make sense.

You need to go to settings>advanced>switch hot and cool

Yep, if the O wire wasn’t making contact, or was always on (shorted to Y or another terminal), then it would default to one mode and be non-switchable.

Wyze is putting out cold and hot air now, Thank you guys for your help.