WYZE Thermostat Not Kicking on AC

Not sure if this is the right place to post or not. If not let me know where I should be and will gladly move it.

So I just got my thermostat today and followed the directions and got it all hooked up. Everything went smoothly till I got to the testing. Stage 1 heat, heatpump, worked perfectly. Stage 2 heat furnace worked perfectly. Stage 1 Cooling nothing at all AC unit outside didn’t kick on or the stuff inside. If anyone has any idea I would greatly appreciate it. Here is a picture of my wiring on the old thermostat and with the wyze. The wire that is hooked up that has a jumper is the R wire.

Wiring looks correct, maybe a bad connection?

It ran properly in heat pump? Started the outdoor unit? Does your compressor have a protection delay feature? Try waiting 15 minutes and testing the cooling again.
(for heat pump mode, it is running the compressor with the condenser and evaporator switched, so if there is a built in delay, it might fail to start the compressor back up for cooling until the time delay has elapsed, or until the pressure has equalized in the system)