Thermostat keeps switching to 'away' state

I’ll notice that the temperature is out of range and look at it in the app. It shows that the device is in the ‘away’ mode, so I change it to ‘home’. Next day it happens again.

First step is to go into the settings and make sure there isn’t a schedule in there that is changing your home \ away state automatically. You can customize this schedule.

Next, go into the settings to make sure your Temp Preferences for these states is correct. You can change these as well.

Lastly, if there is a temp variance in actual temp vs displayed temp, there is a correction setting in the advanced settings.

When you say the temp is out of range, do you mean not what you expect?


I agree with everything SlabSlayer said. Those would be my first checks.

In addition, verify the auto switch toggle. And do you share this with anyone else (either sharing the same Wyze account or shared the device to a separate Wyze account? (spouse, roommate, kids). It could be switching to away anytime one of them leave the house, not just you.

Also make sure there are no automation rules (from you or someone you shared it with)


Good catch! I don’t use geofencing so I never had to deal with that.


Thanks for the helpful suggestions. My only schedules are daytime and nighttime temperatures. I don’t have any schedule that adjusts the home or away state, and autoswitch is off. We do have two phones with the app but they are both set the same way.

When I say the temp is out of range I mean that it is warmer than the value set for the home state. Then when I go to look at controls I see it it mysteriously went to away state which is a higher temperature setting.

I’ve had the thermostat for a couple of years and have seen this behavior on occasion at various times before but eventually it stopped. I did change it from heat to cool mode fairly recently, but the only difference is the temperature setting.

What is the Firmware version of the Wyze Thermostat and what version of the app are you using?

I took a look at my app for my schedules for my Wyze Thermostat (app, FW 1.2.0) and do not find any option for daytime or nighttime scheduling. My only scheduling options are Home\Away\Sleep:

Question on the T-Stat. will possibly be hooking mine up within a week or two, but I have a Humidifier on my HVAC system. do you have a Humidifier as well?

I want to make sure I set it up correctly. Confident I know what I need to do, but curious if you had one as well.

I do have a humidifier on my system with an independent dial humidistat (not smart at all, static manual adjustment setting) not integrated with the old\new thermostat in any way. So, I didn’t have to deal with it when installing the T-stat.

@speadie would probably be a great resource for that.

Good luck.

1 Like

Thanks for the quick response.

I have him in my queue when I hook it up as I already reached out to him.

I have a EcoBee T-Stat currently which makes things easier. The one difference is the Humidifier is a 2 wire hookup and the Wyze is a single wire. I know what I need to do, but was hoping someone could validate for me. :slight_smile:

Here is a video I fond - Nest T-Stat, but same concept:

1 Like

Great resource! That might be something I will do in the future… If I can get my other 100 to do’s done.

1 Like

The firmware version is 1.2.0 and the app is the most recent one.

I see that you have the mode set to Auto. Maybe that’s why ‘create schedule’ is greyed out. Try setting the mode to Cool. You should be able to create schedules for multiple times and days of the week.

I set it to cool and went back into schedules, add new schedule, and my only state options are home\away\sleep.

I have my heat\cool temp Setpoints set for all three states. When setting these up I don’t recall there being an option for me to have only two states. You have had yours longer than I have and I have never experienced any Day\Night scheduling options in the app so I’m not sure I can suggest anything with any confidence.

Create schedule is only greyed out because I already clicked create block to add my time blocks for the specific states. Even so, the only states available for any given time block are Home\Away\Sleep. I do not have Day\Night states.

Here is a pic of my schedules:

Weekdays: Home, Away, Home, Sleep

Weekends: Home, Sleep

Confusion of terminology on my part I guess. Home is daytime and sleep is nighttime.

Ah. Ok. So something is throwing it into the Away mode if you only have one schedule programmed set for Home\Sleep. The only ways I know for this to happen outside the schedule is for it to be done manually from the app, from the dial wheel, or by some programmed automation event, rule, or scene like the GPS Auto Switch. Any rules programmed? Any other home.automation interactions from Smart Assistants?