Schedules not working for me wyze thermostat

Set a thermostat to away and 71 temperature. 3:45 pm. It’s still heating to 77 at 4:28 pm

and staying I am home. I do not want it to heat simply if I am home. I want It to strictly follow the schedule.

If you want it to follow the schedule and not decide if you are home or not, go into the Thermostat settings in the app and make sure ‘Auto Switch’ is turned off

It is off. Have not had it on

I am not completely sure then, hopefully someone else will chime in with another idea

It doesn’t look like you are on the screen for auto schedule. The image of the app screen looks like when you set it to heat and pick a temp to heat to. You need to make sure that the controls panel at the bottom is set to “auto” for the schedule to be followed.

Hard to tell exactly what is happening, but manual override supersedes schedule which supersedes preferred temp.

Ok now I put it on auto, I just set an away status 5 minutes in the future. Let 5 minutes lapse and guess what. No change. This basic feature is not even working.

1 Like

Not saying the UI is good, but the feature definitely works for me so there’s something not happening right on your end. Try putting the away state farther out than 5 minutes, it may not have time to update the schedule in the thermostat before the deadline hits.

Make sure that the main screen has two values on it “heat to X” and “cool to X”. That will let you know it’s on Auto. (the thermosat display will also show an “A” in a circle in the top right.)

Make sure your schedule was saved. I’d suggest deleting it entirely and just do a basic, home and away setting.

Try making it happen farther out, like 30 minutes.

The wyze “wakes up” if it senses motion and auto sets the thermostat to home. So if you are close enough to it, it will never go to away mode.
Hopefully wyze gives us an option to disable this feature in the future.

Wow. Insane. Thanks for that, you’re right. I’ve been walking in front of it. Not to sound too vulgar, but if I get up to take a leak. My heat will go up. Funny… I was thinking it was possessed

Solution… Tape…

if you aren’t really away, you could use sleep as that will not change to home if you walk past.

Just posted a question on this very thing… Should’ve read your answer. It definitely switches when it senses movement.

I’m just changing that scheduling block to Home and overriding the temperature. Problem solved.


That’s the stupidest feature ever! I have to get up and pee at night sometimes!!!

It does not switch when it is in sleep mode, just away mode.

There needs to be an option to follow the schedule. Hope Wzye agrees and adds.

1 Like

I think you’re arguing against part of what makes a smart thermostat “smart”. The idea here being that a schedule works for broad strokes, it doesn’t always cover the reality of what our routines look like. The “smart” part of this isn’t the schedule, it’s that the thermostat can respond to changes in the schedule and adjust the temperature for our comfort without our input.

One case for this would be multiple people. If I trigger away mode by leaving, my wife will get very cold unless she manually changes the settings. This feature ensures that even if I leave the thermostat remains in “home” mode.

A second case is if our daily schedule is altered for some reason and we return home early. The thermostat reverts to home mode without needing us to intervene and picks up the normal schedule at the next schedule point.

Alternatively, Auto Switch can do the inverse. If our schedule changes and we leave earlier, the system can switch to away without our input to save energy.

This is ridiculous. The reason I got this thermostat, a smart thermostat is that I wanted it to heat in the morning and also cool down during the day. Basically I am using three different modes. Since they only allow one mode for a home one more for sleep in one for away I am disappointed with the availability of molds. My idea is that the house cools down before the sleep, then it warms up at certain points at night, and then it warms up again shortly before I wake up. I am home all day. Essentially, I have to use the away mode to accommodate my three preferred temperatures for schedule. And of course I disabled the automatic detection of my home whenever I’m away or not. I had no idea that if I’m home and I select on my way it will change something because I just passed by the thermostat. This makes no sense. Why is he needs to add more options for temperatures because I would like to sell different temperatures throughout the day and not be limited to simply three modes!

That’s not true but also not really clear in the app. Temp Prefs are not fixed, they provide the default for you but you can change the settings for each home/away/sleep block you add. It’s perfectly feasible to set multiple blocks of the same name and change the temps in the schedule to match what you want.

My biggest annoyance is that there is no owners manual. Nowhere to be found. The app is little it intuitive but wyze never provided any instructions to it. For example this setting you mentioned. Also, reading the forum I now find out that if I set the mode to “away” but I walk pass the thermostat, it will change it to a different setting!?