Thermostat Schedule not working

Background: Purchased thermostat in Jan 2023. Schedules have never worked properly. Contacted support in Feb, Apr and Oct 2023. I’ve provided logs, screen shots, answered all questions posed by Support and tried all suggested corrective measures. Support seemed to be satisfied in all instances that settings, schedules, and advanced settings have all been setup properly. The only advice from Support in Feb, Apr and Oct has been to wait for future App or Firmware updates. I thought the thermostat might be faulty and should be replaced, but Support doesn’t believe that will fix the issue.
I’m using the forum in hopes that someone in the Wyze community can help me get the schedules working. I’d appreciate any help at all.

Welcome to the Wyze User Community Forum @Mallard!

I have had my thermostat for quite some time and have wrestled with many schedule issues. There are many posts from me about this here in the forum.

One of the issues with Schedules is the way that the thermostat prioritizes schedules over preferences and will not update the schedules or preferences with new temps when one or the other is changed. Add to that the fact that Behavior settings, Offset, Room Sensors, Differential, and Rules all play a part in how schedules react, and it can get downright confusing and weird.

Please post a screenshot of the schedule(s) in question and a description of the exact behavior it is exhibiting and I’m sure someone here experienced in testing and using the thermostat can help.

Thank-you @SlabSlayer for the quick response and encouragement! I’ve attached screen shots of Settings, Schedule, Advanced Settings (2 screen shots), Temperature Preferences. The behavior is consistent: At 8:00 am when schedule dictates a change from sleep to home, nothing happens. Around 8:15 am every morning I successfully manually override via the Wyze App a switch from sleep to home. At 11:00 pm when schedule dictates a change from home to sleep, nothing happens. Around 11:15 pm every evening I successfully manually override via the Wyze App a switch from home to sleep.
Other App functions seem to work, but honestly I’ve only tried manual override of temperature and switch to Away mode.
I have tried:

  • confirming that firmware is up to date
  • a factory reset of the thermostat
  • deleting the Wyze App and subsequently reinstalling the Wyze App (iPhone 8plus)
  • installing the Wyze App on a different cellular device (iPhone XR)

Any suggested solutions would be welcome and appreciated.

1 Like

The only thing I can think of is to delete that schedule and try with a new one.
or… do you by any chance have overlapping schedules so it might not know which one to use? do you have a screen shot of the main schedule window, before you tap on a schedule to edit it?

1 Like

Thanks for posting those. A couple questions…

  1. Is the “Location” within the settings set by GPS correctly?

  2. If you do not manually override the State, does the Thermostat change states by schedule late? Like an hour late for each?

There have been instances, with some people who travel to other time zones and use their phone and the Wyze App, that the time zone change registers with the Wyze App and the Wyze Servers, thereby also changing the time zone for the Thermostat even though it does not physically change time zones. The issue has been that when returning to the local time zone and the phone reverting back, the Thermostat does not.

Question #2 was to see if there may be a time zone discrepancy in play here. If you have another Wyze Device, like a Cam, you can create a Trigger\Action rule that triggers with the Thermostat being set to Home\Away\Sleep and does some random action. This will allow you to pinpoint the time within the Rules History when the rule executed that it may change state on its own so you might be able to see a pattern.

If it is a time zone issue, you would need to find a way to reset that. I will have to go back and look for the thread when another user had this issue to see how they fixed it if that is the case.

  1. As @speadie already asked, are there any other schedules?

Another option for you is to delete the schedule altogether and use a Wyze Schedule Rule to change the State. Since your Temp Preferences are the same as the schedule, the change in State should default to your Preference Temps. This is not a permanent fix but a test to see if the Wyze Time Zone settings in your server account is true. You wouldn’t want this permanently because it would not work if Internet is lost.

I’ll try @speadie suggestions first. I’ve changed the schedule (see screen shot). I’ve attached a screenshot of the screen prior to schedule edit as per @speadie request. There are no overlapping schedules.
I’ll report back in a couple of days with results and if no success I’ll respond to @SlabSlayer suggestions.
Thanks to both of you

1 Like

Sorry for delay in an update. I’ve been trying some different settings. First I couldn’t see a way to delete the schedule as per @speadie, so I just edited the existing schedule and saved it. I monitored the new schedule for two days. It didn’t work. There was no changes of state in the morning or evening. As for @SlabSlayer suggestions, the GPS location shows my location accurately. I don’t experience any time zone discrepancies for change of state. The state just never changes unless I do a manual override. I do not have any other Wyze devices so I can’t try the trigger rule suggestion.
I did try the schedule rule suggestion and created a schedule rule to change state to home at 7:44 am and a second schedule rule to change state to sleep at 11:05 pm. So far this has worked both in the morning at correct time and at night at correct time for 3 days. This is a decent work around but may not be desirable as a permanent solution.
Now that @SlabSlayer indicates that losing internet can impact schedule rules, I thought I would mention that often when I open the app there’s an indication that the device is offline, but then it refreshes quickly to the “welcome home” screen.
Not sure if the device does have intermittent offline periods and that is impacting the regular schedules???

Drag the Schedule to the left, this will reveal the delete button.

As I understand it, the schedules set in the Thermostat UI are saved locally on the device. Schedule Rules, however, are most definitely saved and executed from the server.

Question: :thinking: when you tap on Controls at the bottom of the Thermostat, does it say “Holding”?

Thanks to @SlabSlayer for the tip on how to delete a schedule. Deleting the existing schedule and reinstalling essentially the same schedule ended up being the solution. The schedule has been working properly for the last 10 days; switching modes from home to sleep in the evening and switching from sleep to home in the morning.
Note: I also deleted the two rules I had put in place as a temporary work around to get modes to switch. Those rules are no longer required now.
All is good and unless something happens to disrupt the schedule, I consider this issue solved. Thanks again to @SlabSlayer and @speadie for the help.

Have had nothing but problems since installing our thermostat. After first it was the scheduling issue many fall into, corrected that & was hopeful. Nope, I’ve factory reset several times. Now with winter kicking in it’s becoming a safety issue. Tried unsharing & only having access via one phone, nope. Tried having access on no phones, nope. Same thing, preferences get overridden, can’t get heat to stay on if trying to use app. Hell we’ve woken up with it being in the low 50’s & still having to fight for 30+mins to actually get it to kick on & stay on. I will be replacing the unit out w/ a different brand this coming month. Used to be a huge fan & raver of Wyze, but not anymore. Smh.

@Mallard - I would like to point out that support asked you to delete the schedule first thing.

This would be classified as user error because you didn’t understand how to use the UI. Even when provided instructions.

I think you owe support an apology.

@itdoesntevnmatter - Seems like this might be a user error thread.

Send a picture of your previous wiring and Wyze wiring.