Thermostat - Why doesn't the schedule work?

The schedule kinda sorta seems to work sometimes, but most every morning when I wake up, it’s cold.
The actual thermostat says Away (the “A” inside circular arrows icon), while the app says “Welcome Home” and that it’s 65, even though the temperature setting is for 73 when I’m home.
It’s cold right now, and for my weekend schedule I don’t have a single “Away” entry, only Sleep from last night, “Home” at 4:00am, then Sleep again at 8pm.
When I want my house warm in the morning, I have to set it manually (with the iPhone app, the dial on the thermostat doesn’t adjust the temperature, only from “Warm to” and “Cool to”, which doesn’t seem all that useful, it’d be better if the dial controlled the temperature)

Anyway, this is a little frustrating, my Wyze vacuum works wonderfully, and has never had problems with the schedule, so I was hoping the thermostat would be equally reliable.

Any suggestions?

The A icon in the circulatory arrows on the thermostat wall unit indicates the Mode, not the State. The A is for Auto mode as opposed to Heat, Cool, or Off. (screenshot below)

The App telling you Welcome Home is confirmation it is in the Home State.

If you have adjusted the Temperature Preferences in the App after having previously set your schedules, the schedules will NOT update with your new preferences. The Schedule set temps for your Home and Sleep times are locked in at the time of setting and overrule any preference temps changed after that point. Any preference temps that get changed after schedules are set must also be manually changed in the schedules or the schedules have to be deleted and reprogrammed as new to pull from the new preference temps.

Drill down into your schedule for each of the time blocks and thermostat states and verify the set temps within the schedules reflect what you are expecting.


That seems to have done the trick.
Thank you for the info!

1 Like

Glad you got it solved! :clap:

You are quite welcome! :+1: