Thermostat Beta Firmware 1.1.5.b1

i see this was released. Does anyone know what is in it?

Good question considering the firmware page lists the other products but not the thermostat.

1 Like

Yeah I noticed the same thing, only thing is this when I try to update it pukes immediately. I noticed that the differential adjustment showed up in advanced settings a week or two ago. Just in time for the end of my heating season. Must say is tighter swing tho w old Boiler Radiators in my early 1900s drafty home…

It took some fiddling, but I finally got mine to update. Don’t see anything offhand that is new or much different.

All I have to say is congrats Wyze for pushing an update out. Not home to load it up but will later.

Must have been PUKING because was updating, Once took update took a peek but see nothing at first glance that appears any diff. Will check out change log and see what Wyze has to say…

The temp differential is 5 degrees F apart. That is wayyyyy too big. They need to fix it. If I choose comfort over cost, I want that range to be 2 degrees F max.

Under advanced in the settings an adjustable differential is now present. I set mine to .5 from the +1 and -1 default and have noticed a tighter swing for sure. Cycles more often but less over all time running. I’m in and old 1900’s drafty balloon construction house w water boiler and large cast iron radiators. Def an improvement for me.

I have not been able to get my firmware to update. It just will not do it, so I will wait until later and see what I can do. The 5-degree difference might be why I am using more electricity now than with my old thermostat. I have a heat pump and the heat strips might be coming on to catch up before turning power back to the heat pump.

Give it a bit… There was no indication it was updating, just continuously failed over and over 5 times or so. Went back couple hrs. later and was up to new 1.1.5.b1. NO INDICATION IT WAS UPDATING AT ALL… But now there, I don’t see any changes myself and cant find change log so just going to believe was for the better.
Cheers!

We may be talking about different things. The Temp Differential is now user defined and provides plenty of options. The temperature gap between heating and cooling is 5 degrees, and I have seen an update for that. But I still haven’t been home to do the FW update. I just hope the Stage 2 heat for gas furnace has been corrected which may require reset and setup…here’s hoping.

Thank you for clarifying those two things. It will help understand how it works.

My experience for this was a bit odd…

I have 2 Thermostats for Zone Control.

As a Thermostat User: :slight_smile: (User Story)
I went into the Beta app and into the “Bulk Firmware Page” and the Downstairs thermostat is “offline” even though I can access it from the app :man_shrugging:

So, I went to the Upstairs thermostat and it said it needed to be updated, click, click, click, click… nothing.

Closed the app and reopened the app and went into the Upstairs Thermostat device vs. the “Bulk Firmware Page” and was greeted with Firmware update notification, click Upgrade and got a “whoops something went wrong” notification.

Thought Meh, the heck with it… walked past the Upstairs thermostat and noticed the screen said updating. I watched it and it restarted. It’s updated

Access the Downstairs Thermostat that says it’s “offline” in the app, and greeting with the firmware update…, click update, instant 'whoops something went wrong" 4 or 5 times over… guessing it’s because it thinks it’s offline?

So I factory reset the device, remove it from my list of devices, re-add the device and now it’s online again. Go into the device, greeted with the firmware update again…

“whoops something went wrong” back into the the Bulk Update Page, click update, nothing happens on the app, a few seconds later the device says it’s updating… for 20 minutes the app still says it needed to update but the device shows as updated

Oh yea, and was this firmware update announced anywhere?

So for the Wyzards, Project Managers, Product Owners that may or may not read this… updating from the Device page in the app appears to start the firmware update, even though it does not appear to, and the firmware bulk update page is just busted.

I updated FW even though the app said “Update Failed” twice. Then I noticed the “Updating…” on tstat screen. After update, I scanned app and didn’t see any obvious changes so I decided to reset tstat and redo setup to see if any changes (hoping for Stage 2 working!). Too hopeful. Now I am trying to “Finish Setup” and it’s hanging and not completely. You gotta be kidding me! Attempted 3 times. Nothing! Dead tstat. Any ideas??

Discharge the power? As in unattached from the wall and reseed?

Appreciate the suggestion! Tried that but no luck. Still spinning on “Finish Setup.” I rolled app back to current one posted on App Store, no luck still spinning.

@WyzeChuan @WyzeGwendolyn is there a way to rollback the Beta Firmware? Getting stuck on “Finish Setup” and have tried a lot of troubleshooting. Currently, a non functioning tstat and no backup option. Any help would be appreciated.

Did you try disconnecting any other Bluetooth devices connected to your phone during setup? This seems to be a trend with the WYZE devices that use Bluetooth. Especially smart watches.

Thanks for the suggestion! I appreciate it. I disconnected all Bluetooth devices. I restarted my phone. Confirmed no Bluetooth devices are connected. Restarted the set up, and it gets stuck at finishing set up step. I believe I’m getting connected to the tstat since it starts to set up process, communicates with the cloud through Wi-Fi, and I think it’s trying to pass the set up parameters to the tstat at which point it never completes.

Maybe Force stop WYZE app, clear cache, launch then try setup… oh but you said you removed the Beta App and tried with production app. So that may not work either… ummm maybe a WAP/Modem reboot if not to disruptive? Could be a used lease in the network and it’s trying an IP already assigned to the original setup not allowing it to communicate and a network goose will release and hand out something new?

All good suggestions! Rebooted network. It slipped into tstat app, but without any device details. Was able to delete the device and cleared cache. Sam issue next setup. It did get recognized by Alexa, but didn’t proceed past Finish Setup. Appreciate the ideas!

Unfortunately, I left my second tstat at cottage last weekend (haven’t installed yet) so can’t go to backup device which is 4 hrs away.

If something doesn’t change by tomorrow, will have to go to buy a new tstat. I can’t revert to old one.