Thermometer thinks it's zero degrees

My thermometer thinks it’s zero degrees Celcius (32° F) but it’s actually 20°. Please help!

Welcome to the Wyze User Community Forum @tyke9! :raising_hand_man: Glad to have you aboard! :grin:

That would be a tad bit chilly!

There is a temp correction feature within the thermostat, but your variance is far outside the range for it to correct.

  • What Firmware is installed on the Thermostat?

  • Are you utilizing any Remote Sensors with the Thermostat?

  • Have you tried pulling the Thermostat from the wall, waiting a couple minutes and plugging it back in?

  • Have you tried a reset \ reinstall?

If, after all efforts to reset it, you still have a 20° variance, it may be a defective temp sensor in the unit and will need to be replaced. Contact Customer Support to report the issue and request a Warranty replacement.


Thank you SlabSlayer. I have been speaking with customer service but they have not yet come to the same conclusion. They keep wanting me to jump through the same hoops over again. I am confident that you are correct and hopefully customer service will agree soon. In the meantime I can only turn on the heat or AC by putting it in test mode!


If your temp sensor thinks it’s 0° in the house, and you have it in heat mode set to say 20° setpoint, shouldn’t the heat work constantly trying to push it up to 20°? You would just need to shut it off manually.

The cool won’t work because it is registering a temp already below the setpoint, which can’t go that low.

I believe this is caused by a bad/disconnected thermostat temp sensor. IIRC there was a recall of some sort for one of the batches of thermostats due to improper shipping?

1 Like