Wyze Thermostat stuck at 32°

So I set up the Wyze Thermostat yesterday. Test went smooth and everything was working decent and wires were hooked up properly after attaching the C adapter.

This morning I woke up and the thermostat was stuck on 67°. The dial wouldn’t even change it, Just stays on the black screen saying 67 and the heater wouldn’t actually turn on. The mode cannot be changed either. No matter how many times I change it, it switches back to “OFF” by itself after a few seconds. This does the same thing on the app as it does on the device itself.

I’ve went through the scheduling and turned that off so it should just be basic controls but it still wouldn’t work.

I unmounted the thermostat for several minutes and popped it back on. Now it’s acting the same but staying at 32°.

Tests still run perfectly and that’s the only way I can get the heater to turn on right now.

I’ve tried hard resetting many times and removing it from the app and re-adding the device. Also firmware is up to date.

If anyone can help me get this thing to work like it should, it would be greatly appreciated!


Same issue and also don’t seem like its heating or cooling during the different stages. Plus tells me my y2 wire is missing

Same problem here. The thermostat never actuated the heater no matter what I set the temp threshold to, and the dial did nothing. I tried running the test again a couple of times and it would run the blower only for about a minute, not long enough to get hot air. I had to put the old thermostat back on so we don’t freeze.

There doesn’t appear to be any support for the device from Wyze. I’m going to have to return it.

Same type of problem - heat test worked fine on and off, but after that Thermostart said 32 and wouldnt do anything else - no one can tell me if thats an error code or false temp or defective device… I had to put the original thermostat back on also ( I did try multiple factory resets )

Same problem here. It’s wired correctly. The test runs and both the AC and the furnace work fine in the test. It’s connected to the app. But it’s stuck thinking it’s 32 degrees and 0% humidity. It won’t even switch modes to Heat or Cool from “Off” at the dial, and I can try to change modes with the app and it looks like it’s doing it, but it never runs and after a minute the app switches back to “Off” mode. I can turn the Fan to On and the fan will run. I’ve done the long-press reset a few times. Power-cycled it. But it won’t come off of 32 or do anything.

Seems like the 32 must be some kind of fault mode…I would think if it really thought it was 32, the heat should run to enforce the “Minimum Safe Temperature” of 40 degrees, that’s supposed to run it below that temp even if the mode is “Off.” But it’s not doing that. It’s just sitting here like a brick.

Turns out my furnace is 208/240 V

Has anyone attempted or been able to send logs on this issue, if so can I have the log numbers.

I’ve attempted, but I can’t even get to it in the app. Sent an email to support yesterday morning but no response yet.

Seems like there should be a way to do that from the cellphone app. Mark the device as not functioning, type in a description, and the logs would be uploaded or flagged.

I’ve reported this to the team. If anyone has support ticket or log numbers they want to post here, I’ll get them where they need to go!

Logs can be submitted through Account > Wyze Support > Submit a Log.

1 Like

Hi JDeezy,
Sorry for hearing about your experience. I have sent you a message to start our troubleshooting.

1 Like

Hi Capstan,
The signal our thermostat sent to the HVAC control board can be overwritten by the internal logic of the board. We have seen some users’ systems will 1)turn on the fan 2) turn off the blower fan and turn on the inducer fan for the heat 3) turn on the blower fan later when the heat is sufficient. Does your system work in that way? or you never got enough heat comparing with the old thermostat?
Looking forward to hearing from you.

1 Like

Has anyone found a way to clear the “32”? I’m on the 2nd day of just waiting for a reply from tech support, which I doubt IF i get a reply will have a solution ( it rarely does until the 3rd or 4th reply)

1 Like

So I ended up calling Wyze at 844-999-3226 and they said that it’s a known hardware issue. They’re sending out a replacement unit and a return label. You guys may wanna give them a call to start your process too.

Thanks JDeezy !!! I gave them a call and was prepared for a LOOOOOOOONG hold, I was really suprise to get through immediately. A 20 second conversation then a 20 second hold and they sent me an email to get the process for a replacement going… I dont know why this didnt happen 2 days ago, I’m still waiting for a reply from that contact with them.

1 Like

I initially had the same issue with mine immediately after install. Then I found that the t’stat is shipped with the control mode set to “off”. It took me a while of playing around with the unit and the app to figure out that you have to change the mode to either auto, heat, or cool.

Hey, thanks for the tip! After you mentioned that I hit the ‘controls’ button on the app. Sure enough the ‘mode’ was set to off, I set it to auto and things started working properly.

1 Like

Yeah, glad it worked for you. Like I said, it took me a while of messing around with it to figure this out. I just can’t believe that after all the people complaining about this, Wyze (@WyzeChuan) hasn’t figured out that it’s as simple as turning the mode to “on”.

The problem is that there is almost no documentation. No info about what the knob does (I didn’t even know you could push it until I saw it here in the community forum). Nothing about how to reset the device. This is a huge omission on the part of Wyze. The app will walk you through the initial setup, but woe unto you if that fails somewhere along the way. After that, nothing.

Yes, instructions are lacking. Due to this oversight, I wouldn’t doubt if they’re getting a lot of unnecessary returns on perfectly good units.