The small switches I bought won't connect

I installed the switches they wouldn’t connect I spent an hour on the phone with a lack of customer service. I paid an electrician to come out and check the installation. It was correct. Spent another hour talking to someone who doesn’t know how to help a customer. It always gets to the same place and locks up. This time they hung up on me. I’ve been fighting with this for months. Not the fan I used to be.
When going through the set up I click already installed it then goes to the radar looking screen shows the three switches each in their own circle and each with a different number in the circle. Then after a few seconds it locks or if I select one it locks, the next screen never shows. So they are just switches. I have Kasa switches and a host of other wize things I’ve installed and set up so pretty certain it is not me. The lack of customer service is my biggest complaint

Sorry your having issues setting up the switches, have you tried using a different phone to set them up? It sounds like the app is seeing the switches but is failing to connect to them. Could you send some screenshots of the screen it gets stuck on?


Here is a screenshot. I replaced my phone just last week and tried my wife’s phone still nothing.

So if you click those bubbles it doesn’t do anything?


And the same behavior happens on other phones?

Did you try hitting all the different switch bubbles, or just one?

Yes everytime is the same every phone

Can you check if you have location set to always allow and Bluetooth enabled on the phone?