Support issues

I have tried to resolve an issue with defective switches without any success. I have contacted support more than 8 times, received emails requesting reply with photos and description of problem and have sent and resent photos, etc and still no one is able to help. I have been disconnected from calls after being on hold for more that an hour and when I ask to speak with a supervisor I’m told that one is not available.
Wyze customer support is the worst that I have seen and utterly and completely frustrating and and disappointing. I have 19 other devices which work about 60% of the time, but the switches are poorly engineered, poorly constructed and fail to be found by the app, even when they’re 8 feet from the router.
Wyze products are ok, but their customer service & support is a horror.

Sorry to hear of your issues @k4zmb.

If I may, what issues are you seeing with your Wyze Switches?

Do you have ticket numbers for your interactions with Support and the switches?


I have multiple ticket numbers, but the only responses to my multiple submissions of requested photos & info are more emails asking for the same info that I submitted multiple times.
My issues with the switches are: 1) failure to be found by the Wyze app, even when 8’ away from the router; 2) Broken screw contacts; 3) clicking sound and faint smell from the switch when attempting to install it.
The replacements I received had same problems. Customer support is horrible and no one is reading my email responses.

Not sure what all troubleshooting steps you have gone through, so note that my response is without some knowledge.

Having a number of these devices installed in my home as well, the clicking is usually an indicator that the line and load is reversed, or I believe I have also heard this if the neutral isn’t fully connected.

If the clicking is present when you try to set the device up in the app it will not establish a connection because it is not getting the proper power.

Have you tested the wiring?

I have read of some others having issues with the posts breaking, I personally did not have this issue using a hand screwdriver and limited torque, but given some of the posts I have read, it seems as if there could possibly be a need for better screws. Even still I have a high level of confidence with these installed in my home.

I tested and labeled the wires to make certain of load and line wires. With the other switches I have tried to install, the app says device not found, even when the switch is 8’ from the router.

1 Like