The pop-up for my cam plus subscription isn't appearing

I bought a cam plus membership about an hour ago. And, according to the help pages, I should be getting a pop-up in my app asking me which camera to apply it to. This is not happened. Am I not waiting long enough?


In the app go to account…services…Cam+.


Yeah, I already did that. The only thing listed there is the panic button service. In fact, when I click on my account, The first thing there is an advertisement for cam plus, with a button to reactivate my account. I click that and it tells me to go to wys and then to services. I go there and can’t find anything regarding services whether I’m logged in or not.

I should also add that my credit card was in fact charged. So I know the order went through.

1 Like

Okay, I did find services, way down at the bottom of the homepage. It shows that I have a cam plus subscription and it says “you have one camera active on annual subscriptions”. Today’s date is next to that. But what I can’t find is how to assign that subscription to a particular camera, of which I have three.


If you’re not seeing Cam Plus under services, restarting your phone may help to refresh the Wyze app.

As hemi has mentioned, under Services you should see Cam Plus. Tap on it, the available paid license should appear under Cam Plus.

Activate Cam Plus > Edit

  • Tick the box for the desired cam, tap activate.

  • To deactivate a cam, Untick the box for the desired cam, tap activate.

Steps to activate cam plus, tap Account > Services > Cam Plus > Edit > Available Devices


Thanks, but no, I do not see that under services on my phone. The only thing I see is something called emergency button (pilot). Yes, I did restart my phone, a couple of times, still nothing. I do however see it on the website that I have purchased it. I’m using an Android phone and all of the applications are up to date.

1 Like

Also, this is what I see on the website:

…but noting on the phone. App, Firmware is all current.

Ok stupid question but are you sure you are using the same account, (email address), on the services site that you use on your phone?


Good question actually. I just double checked, Yes, I am.

1 Like

Man I got nothing. If it were me, I’d delete the app and reinstall it before trying to contact support. You won’t lose any settings. Good luck!


Good advice uninstalling/reinstalling the app. If that doesn’t help here is the number for Wyze support.

1 (206) 339-9646

Available Monday - Friday 5 am - 6 pm PT and Saturday 8 am - 4 pm PT

Submit a Request


Yeah, got an email thread going with support. I’ll post here what they find. Nice response by them.

1 Like

I have the same issue. Was working great during the pilot but after purchasing a subscription to help Wyze fund the service. Have no more option under services to toggle on either CAM plus or person detection for any of my cameras within the latest app update.

I’ve tried the following:

  • Restarted my phone.
  • Logged out of the app and logged back in.
  • Deleted the app and reinstalled.
  • Went back a previous version of the app then updated back to latest version.
  • Logged into my account to ensure the service has been purchased.

Cams on v4.9.6.199 App on v2.15.21

Currently have a service incident open with Wyze support.

Called service today for the same thing. They have no idea. They were very nice about having no idea, but they have no idea.

I am now having the same issue. Cam plus is not showing under services but on the web I have 2 subscriptions. Has anyone been able to resolve this issue?

Same problem here. All I’ve got under services is Emergency Button (Pilot). On the account main page there’s a big header that says "CAM PLUS PLUS MEMBER then under that “Activate your service.” but when I click on that it says to add Cam PLus visit and click Services in the main menu and then there’s a button for “Remind me later.” When I go to and go to My Account then click on Manage My Services it says I have “Cam Plus (BlackFriday)” and that I have one camera(s) on annual subscriptions. It also says “To use Cam Plus on your Wyze Cams, open the Wyze app, go to the Account tab, tap “Services,” tap “Cam Plus,” then assign your newly purchased license(s) to the device of your choice.” Cam Plus isn’t there though in my app, so I can’t do that. Interesting.

just bought the cam plus service and encountered this problem. I’m glad I’m not the only one.

1 Like

Having the same issue as everyone else here. Bought the Cam Plus/Free v3 Black Friday deal. Tried all the troubleshooting in this thread to no avail. Has support resolved this yet for anyone?

1 Like

I was on a chat with Rodrigo V for about 45 minutes yesterday and the ultimate answer was: “(05:12:01 PM) Rodrigo V.: We allow up to 1 week from date of promotion purchase before it can be seen in customer app/account. This is for making room for the subscription to be placed on customer’s account.”

I’m not sure I believe that, but we’ll see. If that was true I would think he’d have mentioned it in the first minute or so and not 45 minutes in, but maybe that’s just me. I got the impression this was just an attempt to buy time and get me out of the chat. I was also told my subscription wouldn’t officially start until I’d assigned it to a camera so I’m not losing any of the subscription, I just can’t use it yet. It’s clearly on my account as can be seen on the my account web page, it’s just not in the app where I’m supposed to activate it and assign it to a camera. I think the’ve got a glitch of some sort that needs working out and they’re just buying time hoping it gets fixed.