Spotlight for Cam v3 won’t turn off

The Spotlight for my Wyze Cam v3 won’t turn off. The camera and spotlight are on the latest firmware ( When I go to the camera settings and click on Accessories and then on Spotlight, I get an error message saying that there’s No Spotlight Installed (you can clearly see from 2nd pic that Spotlight is on). I’ve restarted the camera on the app and by physically pulling the power cord out. Still same results. Anyone else having same issue?



Can’t explain the “no spotlight installed” message. But you are trying to turn spotlight on at the portrait screen in the upper right corner above the image, correct?

Hi Sam_Bam no I’m trying to turn it off. It used to come on automatically at night/in the dark when it detected motion. Now, it just stays on, even during the day.

Okay, got it. Off. But are you using that little image of that spotlight in the portrait screen above the camera’s image?

Well at the top of that image you can see the bluish purplish haze, that’s the Spotlight bouncing off of the wall. I included that pic to show that the Spotlight is working and on. Plus in that image you can see how the ground is lit up.

I’m sorry. I could have been clearer in my post to you. Let me ask a slightly different question. Is this your only V3 spotlight?

I would say it’s defective spotlight pull a case # and go from there

Ya my only Wyze spotlight.

Ya that’s what I’m considering also.

Sorry for sounding so elementary. Do you see the button/icon to turn the spotlight on and off - in the app?

Nope. I used to but not for last few days or so.

On the app, select the camera from the main page, and it opens to a single portrait style page where the settings icon (wheel is in the upper right corner. (By the way, at the bottom of this page/window you see “View Playback”. That’s how you know we are on the same page.

The image the camera is displaying is in the center of this page. Directly above and outside the image is “Live Stream”. To the right of “Live Stream” you should see the outline of an oval that indicates the spotlight on/off button, if the camera has a spotlight installed. When the spotlight is on, the oval appears to be lit up. When the spotlight is off, its just the outline of the oval. Do you see the oval or the oval lit up? If not, then seems you may have a bad spotlight. Best I can do.

My spotlight will turn on with motion, but then never turns off. I am able to turn it off remotely. The firmware for the v3 is up to date and the spotlight says it’s up to date but it’s and I think it should be I’ve unplugged the v3 for over a minute and uninstalled and reinstalled the app.

1 Like

After several days of back and forth with wizards of Wyze they said after consulting with the product team there is no mechanism for the spotlight to automatically turn off.
So throughout the beta testing no one noticed it did not turn off by itself, really?
They said I should create a wish list because that’s the best way to let them know we want a light to shut off by itself.
There are several examples of wish list items without one comment from Wyze in years.
Apparently Wyze is more concerned with releasing new products and not adequately testing and servicing existing ones.
I’m done with Wyze as products need to be replaced I’ll be doing it with other manufacturers.

1 Like

I had a similar issue, maybe mine is similar to yours? I found this thread this morning and after being frustrated. I think I found a solution, accidentally.

I bought this cable which is definitely not a stock Wyze USB → MicroUSB cable because I needed a longer run to the camera in my attic.

I was using the stock Wyze power brick which is 5V / 1000mA from the printing on the brick itself. This worked with my Spotlight for a time (weeks? a few months?) when the camera/spotlight were brand new. Even with the non-stock power cable.

Then I noticed the other day the Spotlight was on and I couldn’t control the spotlight from the app any longer. Power cycling didn’t work. Firmware updates, didn’t work.

I thought maybe the camera / spotlight got water in one of the connections, so I brought it inside to dry out. I happened to have a USB → MicroUSB cable for headphones on my desk where I placed the camera. After letting it “dry out” (this wasn’t the problem) I plugged the camera in and suddenly the Spotlight started working fine again! I thought I had my solution.

I reinstalled in the outdoor location only to find the same issue again, Spotlight is on, no control in the app. I then realized the difference of why it worked was the difference in power source and USB → MicroUSB.

I looked around my house for many 5V power bricks but they were all 1000mA with one being 1500mA. I did happen to find this laptop charger was what I was using on my desk and that has WAY more power options. At 5V is says 3mA, but I’m no electrical engineer, so I’m not sure why it worked.

I tried to replace the Wyze power brick with this and now the same camera, with above, non-stock 43ft cable, brings the spotlight icon back in the app.

So in short, if you have this issue, I’m going to guess it is

  1. you are using non stock components or
  2. there is degradation of the Wyze power brick over time; or
  3. there is a bug in the Wyze app around power levels.

My guess is a combo of #1 and #2 and because of that, Wyze likely will never admit to a problem on their end OR support this problem.

I’m running the laptop power brick and will monitor for a few weeks to ensure things continue to work.

1 Like

My specific issue is the spotlight will not automatically shut off after it is turned on by motion detection.
According to Wyze it was not designed to shut off automatically. I find it difficult to believe this issue did not show up in beta testing but, the way Wyze has been pushing out new products I do believe it’s not a priority to fix this issue.
This and several other neglected problems is why I have stopped purchasing Wyze products and replacing them with other brands as needed. Wyze is mostly concerned about new customers and not supporting the ones that have been loyal.


My spotlight attachment on my two V3 cameras for the last two or three night stays on even when there is no motion. The last update switched the control to “on” instead of “auto”. When I switched it back to auto, the next night they turned on again on both cameras and stayed on even with no motion (even though the switch was in the “auto” position). I don’t know what to do so I had to turn it off completely since it is malfunctioning.

The lights on my camera used to turn off automatically when motion was detected. I read above that someone was told this was not true. Mine did- I tested it multiple times in the past. The past 2-3 nights it comes on when it is dark and never shuts off- no motion is detected at all.

And yes. I have lastest app and firmware updates. It seems to have started after the lastest beta tester app update.

1 Like

I have ours set to auto and motion and work just fine put yours on auto and do a hard re-boot

My spotlight does not shut off either from motion detection and then it uninstalls from the cam and won’t reconnect ever. So I went through 5 spotlights since the last update. I can’t be running a lot of lights outside because Mom’s bedroom window is right above and the reflection shines on the awning and keeps her awake. The spotlight was the perfect solution as it didn’t shine that brightly but caught movement on the patio.

Thanks. That reboot worked!