Sense hub won't pair or connect?

I came home from vacation and found my system wasn’t working. I tried to reconnect the sense hub but it showed offline and wouldn’t pair or connect. My solution: I discovered that in my phone (Android), in settings, under app permissions I had to click Wyze on, as it was off. It still wouldn’t work, so I had to go (under settings) to Bluetooth and delete Wyze hub. I next went through the Wyze app to Monitoring and reinstalled the hub, keypad and sensors. Everything’s working fine now, through I have no idea why it stopped working; maybe the problem was with my phone. Hope this helps you.

I have had the same issue following a power outage. My cameras came back online without any issue, but my sense hub and entry sensors won’t reconnect no matter what I do. I’ve submitted a ticket, but will probably end up resorting to deleting them and re-adding everything again.

That’s what I had to do, deleted everything and reinstalled. It was a little tedious, but much quicker than the first time. I also first updated the Wyze app.

Yep. Did the same after trying a number of other things and submitting my ticket. Like you said it was much easier to set it up again than it was the first time. I think part of the problem might have been that my wifi network has both 2.4g and 5g bands. I’m suspecting that when it tried to reconnect, it couldn’t differentiate between the two and was connecting to the 5g band, which isn’t compatible with Wyze Sense devices. Just a hunch.

Same thing happened to me with a power failure. I really hope I don’t have to go through this process again.