Wyze sense hub won't finish setup

Sense hub is hooked up to router, Bluetooth is on, phones on 2.4ghz I’ve deleted app data and made sure permissions were granted it connects says added then times out


Anyone have any insight?

I had the same issue and support did what they could but couldn’t get it working. Then I switched phones, I was originally trying with an android phone then switched to an Iphone. When I did it went through the same process but then asked for location permission and viola it worked. So maybe it’s a location setting or an android issue, not sure but hope this helps. Now after the setup the andriod phone does work properly.

I actually had that same thought, so tried to do set up on my wife’s phone after mine wouldn’t work, still no luck.

Bluetooth is on, location services are on, moved Hub to other areas of the house to try and get better wifi signal (shouldn’t be necessary because signal where it was was best in house), still doesn’t connect.

When it times out/fails to connect I get a “Ensure you’ve powered on your Hub – We couldn’t find any devices nearby” message which is ludicrous since the Hub is plugged in and the lights are active/moving during the pairing process.

I connect to Wyze Cloud just fine, will not get past “Adding Device” portion.

so what ended up being my issue is i beleive my mesh router kit. i had the hub connected upstairs in office on the second router. tried it half a dozen times maybe more and failed each and everytime. i plugged it into the main router in living room connected to the modem and voila. it works great now no issue. i am not sure why as it should not have changed anything.

I just need to connect via Wifi cause my router is in the basement.

This thing is extremely disappointing.

So, I decided to try and hook up the Hub directly to the router because I can’t get it to connect via Wifi.

It worked! Quickly. I was able to connect my keypad and my first sensor without incident. Working to connect second sensor, it won’t connect. Says “move closer to the Hub.”

Move closer to the Hub and get notified that the Hub is offline. Go to the Hub, reset the router just for fun. Now getting a message saying the Hub has no battery even though it’s connected to power like everything else connected to my router is.

What the **** Wyze?

Same issue and it’s a year later.

I had a similar issue, and even when I got the setup to work, it would simply go offline again soon after that. Furthermore, it has something to do with the wi-fi settings in the hub. However, I can recommend hooking up your hub directly to your router.

I noticed at one time a message showing up on the app when my hub was offline that no internet was available - and subsequently, it showed me that you need to keep it linked to your router. So, that is what I did, and it works.

Yes - that is an issue that I think needs to be addressed. But there is a security reason why you might want to do this anyway: and that is because this way, your hub is linked to your cable directly. If your wi-fi is not secured enough, it might be easier to ‘break’ the connection between your router and your hub, which is less likely while hooking it up directly.

So, yes, it should simply be working. But this minor nuisance is not a bad way to fix the issue.

I’m directly connected to my router. I’ve tried it wifi as well and it see’s my wifi and let’s me connect. Just doesn’t want to finish the setup. I get a connection timed out message every time.

I just had a thought… only because it applies to the Wyze Thermostat and these other brand smartplugs… when installing those, in order for it to connect to the WiFi, the GPS Location Service has to be on. Don’t know why… but it does. Has anyone checked to see if that is an issue?

@Birm - I saw the same thing happening once I had my hub working: Move closer to the hub. But, ehm… no… my back door was here, and my hub immovable (as it is now hardwired to my router) was over there. And I rather not have my sensors in a place where the hub cannot even set them up. Call it being paranoid.

However, that might not be the issue. The hub placement is less of a problem than having anything metal or electrical wiring between your hub and your sensor. Mostly around your hub. I can tell you that the hub has a broader reach than you would give it credit for. Our house is pretty big, and the hub is in the basement at one side of the house and has no problems reaching the top floor on the other side of the building.

But make sure that your hub has no metal or major electrical lines in the direction of your sensors. For example, our hub is right next to our breaker box, with two massive solar batteries next to it. But not in the line of ‘sight’ to the sensors, and it works perfectly.

So try that - and leave the hub hardwired. As I explained in my other response, I don’t think leaving it connected to your router is terrible.

FIXED - Hub won’t finish setting up.

I did this by getting a new hub,

Problem solved.

It’s good to have modems and routers centralized in one place, such as the basement, as I do. However, it’s a good idea to run a CAT6 cable and simply add a switch to connect your main electronics to it that are most used by you or the household (TV, PC, gaming console, wyze hub, etc.). It’s also not the worst idea to run another CAT6 to the center of your home and add a POE access point for more reliable wifi coverage (or just cascade another router if you have it) and most of your networking needs will be met with no issues.
Also, stay away from **band steering"*, AKA “Smart WIFI”, as per my ISP’s modem/router/ashtray that my ISP forced on me, as it’s a cable company that provides fiber to the home with no ONT [Mod Edit], just a fiber modem that has a forced built-in router that’s not accessible to change settings to your liking. YEAH, I’ve lost my [Mod Edit] on them after the install as their “smart wifi” was not something I was able to disable or their forced router that they wanted a $10 rental fee just to piss me off even more lol… [Mod Edit], I’m probably the only one that does NOT pay that fee as I ripped every department possible within that company while having them disable everything possible on that forced ashtray they provided. I have yet to see a cable modem that supports fiber. So I can’t buy my own even if I wanted to. That needs to end up in a class action eventually because that is [Mod Edit], despite their cheaper price for 1 gigabyte download and 1 gigabyte upload speeds on a very consistent level. The reason I’m still with them

Anywho, if you don’t have [Mod Edit] as your ISP provider and use your own equipment, make sure to disable that junk as soon as possible. It combines 2.4GHz and 5 GHz signals into one SSID, wreaking havoc on all your devices that still require a 2.4 band ONLY in order to operate or even connect too. It’s best to disable and use separate SSIDs, (one for 2.4 and one for 5 GHz), keeping the same password for both in order to simplify things. Just don’t make the password too easy or I will hash-cat you myself lol.

For older sensors that don’t want to reach my hub that’s connected to the switch, I’ve simply used my wyze first gen cams with a USB port on the back and simply used my USB accessory dongle hub thingy? to help get those going. Back in the day before the hub became available along with V2 products, I believe that was the only way you were able to connect any sensors or other wireless accessories available at the time. I’m not sure if you can still buy one, but it does come in handy.

MOD NOTE: Post edited to conform to the Community Guidelines.