Rules only seem to apply to first device in the list

I have rules set up to turn on 5 cameras on, and set notifications on. Another rule turns notifications off for those 5 cameras.

However, when I use the rule to enable notifications - it ONLY sets notification on for the first camera in the list - not all of them. I’ve played around with 2 cameras - same thing, ONLY setting notifications on, using the group to turn notifications on - nothing matters - will ONLY set notifications on for the first camera/device in the list for the rule.

This worked before, and I don’t know when it broke - but it does not work now.

Can you post a screen shot of your rule, with all actions shown?

1 Like

This is with camera groups - but had them all in the rule individually too. Same result. Hit the shortcut/rule button and it flashes once or twice and is done. When it worked before seems it would flash once for every device in the rules list. Now - just one flash no matter if camera group is used - or individual devices are used. I’ve deleted and rebuilt several times.

The “off” does the same thing. If I manually set one of the cameras “later” in the list and hit the off - doesn’t turn the notifications off. Again - just hits the first device and quits it appears

Looking at your rule, you don’t have the “enable notifications” action, you are using “enable motion detection”, which is a separate action. So when you press the shortcut that you have pictured, it’ll turn the cameras on, then enable motion detection. It won’t change your cameras notifications settings at all. Actually that in itself is redundant and unneeded because when the camera is off, technically motion detection and notifications is to.

What I would do you if your use case is “when cameras is on, detect motion and notify me, and when cameras is off, don’t detect motion and don’t notify me”. I would set your motion detect to on and notifications on for all your cameras, then use ONLY the “turn camera on” and “turn camera” off actions in your shortcut.

I’ll play with it some more - this is just a shot of the last settings that I’ve changed 8-10 times to see if ALL the devices in the list perform the function (whatever it is) that they are supposed to. I’ve changed to use various functions. Again, no matter what the function(s) is/are - it only turns “on” for the first device in the list - not all of them.

Ok - took a while before it got fixed. What I’ve done:

  • Deleted devices and re-added (several times)
  • Removed devices from rules to only one device, then re-add to rule
  • reset devices
  • Multiple combinations of the first 3 items above
  • change rules around to see what might be working, etc

None of those seemed to make a difference. Rule would ONLY get applied to first device in the list for the rule.

What “fixed” it:
During the week of 12/20/21 - there was an app update on 12/21 (2.27.32), and following that, there were also device firmware updates (Pan cam, V2 Cam, Video Doorbell and Wyze Cam Outdoor

After getting that app update (I keep my app updated ALL the time), and pushing the firmware updates to the cameras (I had Pan Cam, V2 Cams in the ruleset I had a problem with) - everything immediately worked. I do keep device updates up to date every 2-3 weeks, and will check app updates every few days on my iOS device(s). All Pan Cams were on the same previous version, the V2 devices were on their respective previous versions also, So all Pan Cams were on the same version prior, same with the V2. Not a mix of firmware versions.

So something about pushing the firmware to the devices and possibly the app update shook things loose, and now my rule is working. It also has gone back to “pulsing” the rule when it is pressed multiple times, looks to be once per device in the rule, or it just pulses until it’s done with all the devices. When it wasn’t working - it would pulse only ONCE. Thus, only the first device got the rule “push”.

So with the latest updates - all is now working again.

Can you post a picture of the “pulsing” rule? Make sure you scroll to the bottom and all actions are visible in the screenshot. I’m curious as to your actions.

Group consists of 3 v1 pan cameras, and 3 v2 cams

This same rule DID NOT work until after the cam firmware updates and the app update. Since I did those together, I can’t tell you if just one or the other did the trick, or it took both.

Wierd, thanks for the note. If you have motion detection and notifications enables at all times when the camera is “on” you dont need to have those actions and can trim those off and only have the “turn on camera” rule. While the camera is “on” go into its settings and enable motion detection and notifications to your liking, then the “turn on” and “turn off” actions of the rule controls those also. Relate that to when you turn on your car, you dont also have to turn on your radio and set its radio station if that’s the radio station you always listen to, because turning on and off your car will control the radio also. If you ever have the cameras “on” and not have motion detect enabled or notifications enabled then disregard the trimming of the above.

Yeah, The reason I do that is to make sure all are powered on. I have an “enable” and “disable” rule. The reason for that is with storms, etc the lightning, rain, etc. freaks the cams out and I get notifications all night long. Sure, I could disable the notifications for overnight, but that becomes a bigger issue as notifications on an iPhone are by app - not by device defined in the app.

Having these rules allows me to just disable the “problem” cams that get messed up when weather strikes (just a few days ago, we had blowing snow - not even heavy - and my doorbell was going off every 3-4 minutes ALL NIGHT until I disabled notifications for the doorbell. I may need to add it to the “off/no notification” rule - but hate to do that. Have to see how its affected the rest of the winter.

Anyway, I generally have a schedule that re-enables notifications about 5am, just in case I forget to re-enable them after I’ve turned them off for a stormy night. I live “in the county” near a small town, on a distinct enough rise that the winds are almost always terrible at my house. Blowing leaves, etc is always setting cams off. If it gets too annoying, I just disable hit the “off” rule to disable notifications for a while for the “problem” locations.

The rule actions of turn on and off are just software on and offs, they don’t actually power off the camera. It just puts the camera to sleep, but is still powered of and awaiting an “on” command.

On my Android I can control the notifications from the app that way to. There are three ways or tiers to disable notifications. 1. Device settings in the Wyze app. 2. Wyze app account settings. 3. Android is settings for the Wyze app. If ANY of those three are off I won’t get device notifications, but ALL three need to be enabled to get device notifications.

Gotcha, no prob. Wanted to point out a redundant redundancy but doesn’t look like that is in play here. Thanks for the use case!

I just decided to be “safe” and power things on first. I’ve had occasional instances where cameras would just be “off”, and I’d have to power them back up. Been busy the last couple years with aging parents, and didn’t spend too much time experimenting with issuing commands when it was “powered down”. So figured it was “safer” to turn them on before issuing other commands.

And notifications work pretty much the same on iOS too.