RTSP Firmware changes Mac Address Randomly

Been having this really weird thing happen. I’m using my Wyze cams with RTSP, streaming through BlueIris to ActionTiles. Everything works fine, but every so often one of the cameras stops responding (random when this happens and which camera) I check the app and the camera won’t respond. After a few minutes, it comes back, but when it does, it has a new Mac address. I’ve confirmed this since my router has a history of past devices. I can see the last time the camera connected through wifi and it had a different Mac Address and different IP. This throws BlueIris out of wack since I have to go in and change the IP address in the link.

Anyone else experience this or know why this can happen? I have IP reservation turned on on my router, but since the Mac address changes, that breaks.

Looks as if you’re not alone.

How strange. The Wyze firmware must be spinning up another MAC address for treating the RTSP as a separate virtual NIC? That or some kind of tunnel.

There used to be a problem, I don’t know if it included RTSP, where the camera would randomly switch between its Wyze hardware address and its network card’s hardware address. When that happened, the Router would issue a new IP address to the second hardware address. The issue would only alternate between the two hardware/IP addresses. Is that maybe what you are seeing? We thought that issue had been fixed.


Yes, I am having the same issues. Mac addresses change so the reserved ip addresses aren’t assigned. Cams can be viewed with the Wyze app but not with 3rd party cam viewing programs.
I’ve put further purchases on hold for now.
I am on the latest rtsp firmware
Pretty disappointed actually. I’ve stopped recommending Wyze stuff all together.

I am hopeful that a remedy can be found.

1 Like

Does anyone has solve this issue? I’m tired of changing the ip in my router every other day.

When this was a thing, I thought it only jumped between 2 hardware addresses. One was the Wyze-assigned address, and one was the internal network card address. That should mean if your IP address lease is a typical 7 days, you would only get 2 IP addresses. If you were restricting network access by hardware address, there would only be 2 hardware addresses to add to the list.

How long is your IP address lease set to? Are you seeing more than 2 hardware addresses? Do you have a current set of firmware?

1 Like

So far I have identified 2 MACs: 2C:AA:8E… and 02:0F:B5… My lease time is 24 hours (Netgear R8500)
I’m not restricting by MAC. I believe firmware is
I’m just looking to other CAMs to change at least my critical one and wait to see if Wyze come with a solution. I had great hope for Wyze 3 and RTSP but looks like this is the end of Wyze for me.

Your biggest problem is the V2’s RSTP software was probably based on the old bugged firmware. Unfortunately, no one expects the V2 RTSP software to be updated again now that the V3 has been released.

I don’t know that the V3 has the issue, no one has one in the field yet. However, there is no RTSP software for the V3 yet either, but that means it should be based on newer firmware.

What exactly is the issue? If you are port forwarding at the router then reserve two different IP addresses, one for each MAC address, and then forward two different ports to the two internal IPs. From outside, if one port is non-responsive then just try the other.

Even better, some routers will allow you to reserve the SAME IP address for both MACs. Problem solved.

Sorry @Customer I’m just and average user. No port forwarding. I just know my cameras were working perfect with the same IP for months but just few weeks ago this crazy thing started.

So best thing may be to simply extend your lease to 7 days so you always know it is one of 2 IP addresses. Or (more advanced) assign two IP addresses to the 2 hardware addresses (that way you can make them fixed and easy to remember).

Thanks @Newshound but looks like extending the lease time in my netgear involve advance skills (telnet) since is not and option in the admin interface. But thanks for the advise have sense.

Here is a screenshot I found on their community site. Have you tried what both of us suggested and link the same IP address to both MAC addresses? It might work…

I gave that a quick shot, and the second hardware address overwrites the first when the IPs are the same. However, you could reserve 2 sequential IPs like x.x.1.100 & x.x.1.101. That way if one doesn’t work because the hardware address flipped, you just enter the other IP address, and you are off and running again.

1 Like

Oh didn’t know you had his router model. I’ve used Netgears but never much liked them.

Telnetting in isn’t that hard; at least he has the option. I could have sworn somebody said Linux on most of these devices had no problem with a duplicate reservation. I haven’t tried it.

I don’t have their model, but I have one that has a similar interface to what you posted.

You may be able to do a duplicate reservation thru Telnet or something, but the HTTP web interface didn’t let me do it.

1 Like

Happens to me about once a day. DHCP spec doesn’t let you reserve the same IP for a different MAC Address. Funny not all my v2 with RTSP firmware do this, but 2 out of 4 do it - Flip flop between two MAC’S and a reboot fixes it. Super annoying and because of this, plus the super aggressive nature of “plus” service and increasing of the cool down period, I’m not sure I can recommend these to folks.

1 Like

One of my Wyze Cameras has started to do this recently, which means that my camera server software (Milestone) looses its connection to the camera. Very annoying.