MAC Address changed?

I rebooted my waze cam V2 today and it showed up on my network under a different MAC address?? Why?

Just to clarify a bit further, the app shows a different MAC then my router is showing. IP is correct on both.

No one from Wyze to comment?

I checked mine and they all match. I’m wondering if your router table is up to date. Have you tried refreshing it?

I have rebooted again and it is still using this “new” MAC address

Just so I’m clear, the IP addresses display in the Wyze app and the router table are the same, but the displayed MAC addresses are different?

How different are the MAC addresses? Beginning, end, whole thing?

Yes the IP is the same , the MAC is completely different

Here’s what I got from Wyze:

The chip has a hardcoded MAC, and then we mask that MAC via firmware, upon startup. Sometimes it doesn’t take though… :thinking:

In his case, the app is most likely showing the MAC that the firmware reports, however the mask didn’t take, so the hardware is using the hardcoded MAC.

Pulling the plug for 20 seconds should hopefully resolve it. I don’t think a soft-reboot will though.

There were tweaks made to the firmware months ago (maybe a year ago?) that were suppose to resolve this.

I hope that helps. If the issue continues, you should file a support ticket on this so they know the issue isn’t fully resolved.


Thanks for the update, when i get home i will pull the plug and see what happens.

Power cycling for 30 seconds did not help, still wants to use the wrong MAC

:thinking: If it matters, then I guess I’d try to re-flash the firmware:

Ill just wait for the next update and see what happens, camera works so not a big deal just thought it was strange and the team should know about it.

1 Like

UPDATE: A second power cycle brought back the correct MAC address.


Not sure I would call it a “solution”, rather a workaround to a bug.

Well, you’re right. It is a bug that was squashed, but apparently has one leg still kicking. However, marking as solution brings it to the top of the topic to let other users know they can fix the problem by this post, whether by solution or workaround or whatever we need to call it.


Jeepers … thought someone was hack stealing my WIFI !!!

Not sure if the reboot will solve this problem yet with one of my new V2s.

But it seem to make/generate a new Mac address overtime by itself, think from a reconnecting or rebooting … not sure.
But from a new set up it comes with a new MAC and new IP.

Not all that sure yet because I disconnected it and replaced it with another new one I had.
After search/finding this post, my time is limited at the moment … I have only 3 day left to return/replace it with Amazon.

1 Like

Happened to me once, too. And because I set up IP address reservations in the router, the new MAC (completely different that the one shown on the camera’s label), the IP address changed, too. A reboot fixed it. However, I still wonder what did that.

This explains so much! I was wondering why some of my Wyzecams don’t always pull their assigned IPs. I don’t remember the last time it happened, but I noticed it a while ago shortly after setting up my first 2.

I have had experience with MAC address’s changing on devices when they bounced on or off of a wifi extender. Some extenders change MAC address. This caused headaches for me with Home Assistant and DHCP reservations.

Anyone experience it bouncing from an wifi extender to the main router with a diferent MAC ?
Is this possible ?

Just chiming in, this just happened to me.

Yesterday I checked on my AP who was connected and found a new MAC that I didn’t know where it was from. Also, because it is my home, I knew more or less what it should be connected (like My TV, cellphone, tablet, computer, my wife and my kids devices, cameras, etc…) and noted that the cam from my toddler bedroom “wasn’t connected”. Checking within the app I could access the camera with no problem at all, so I was inclined to believe that it was two unrelated bugs at the same time.

Just to be on the safe side, I denied external access (internet) to the Rogue MAC (you can break havoc, but no calling home), it was late at evening and I decided to deal with it on the next morning.

This morning I looked at the app and now the camera was reporting as “offline” on the app (and the cloud icon was crossed). But if I clicked on the icon I could see the image without any problem (had local access)

At this moment I clicked one plus one and realized that it was the camera that was with a different MAC

First I imagined “COMPROMISED FIRMWARE UPDATE!”, the camera is now part of a BOTNET, but after a second and thinking “why would anyone change the MAC if they wanted to stay hidden?” I decided to reboot the camera and see what it would happen. soft reboot using the app didn’t do anything, but pulling the plug resolved the issue.

To help anyone on Wyze to locate this, my camera is on the frontier between the main AP and a “mesh repeater”, and I use a Netgear Orbi system of mesh network.

All in all, now we know a few things:

  1. This supposed squashed bug has returned (my firmware version is - up to date as May of 2019)

  2. The wi-fi module on Wyze cams seem to be from Nova Electronics (Shanghai) Co., Ltd, starting with C8:02:8F (no panic if this shows up on your network)

  3. Even if you deny internet access to the cameras, it seem to work just fine locally with the provided app, so good news that if (god forbid) Wyze closes tomorrow, your camera isn’t a complete paperweight, even without a firmware change.

1 Like