Robot vacuum will not power on or charge or reset

My vac was working just fine, then one day it just stopped. I cannot get it to turn on or charge. I can manually turn it off, but when I put it on the dock it just flashes both buttons white. It never indicates it is turning on, nor does it turn yellow to indicate charging. The app shows it to be offline with firmware 1.6.199 installed. This happened at the end of May. It’s 15 months old and customer service refused to offer any support.

I have tried many things to fix this:
*cleaning the contacts with alcohol
*holding down both buttons to reset - nothing happens
*moving dock to a different plug / surface
*leaving it off the dock for days and then trying again
*replaced the battery
*borrowed a friend’s dock to make sure that wasn’t the problem
*disassembled, checked all connections, cleaned interior

Has anyone else seen this and been able to resolve?

1 Like

This was from the last day it worked.

My suggestion would have been to unplug the battery, but you’ve done that and more.

Is it blinking or pulsing because I wonder if it’s trying to get 1.6.202 which has been giving people issues.

I’d say it’s a pulsing white light. It’s not turning on, so maybe the firmware update? Do you know of any way to force it to stop or finish?

I’ve collected some links…

Release notes mentions:

This will be a double update where the 1.6.199 version is installed before the vacuum updates to 1.6.202.

I guess 202 is automatic after 199? Did you approve the install of the previous (1.6.199) update?

something easy to try … take the battery out and jump the connector AT THE VACUUM and leave it jumped for about 10 minutes. Be careful not to damage the pins. If there are any capacitors holding a charge this might clear the bugs.

If all else fails and you want to throw it off a cliff, PM me first.

1 Like

I didn’t approve any updates. I think they just automatically do it.

1 Like