Robot Vacuum Unresponsive - No replacement order update yet

I have had my Robot Vac since January. It has worked surprisingly well. On Friday morning as i was heading off to work i noticed it had an error that i needed to put it back on the ground. My wife and son found it and it was tangled in a cord…no problem. They brought it back to the kitchen and put it against the charging base (like they’ve done many times before). Fast forward to Friday night and i hear the robot say something but can’t make it out because i’m in the other room. I come in and all the lights are off. I tried to turn it on and nothing happened. The app showed 27% on the battery but i’m sure this was just the last info it had when i connected to it on Friday morning. I assumed that they didn’t seat the bot against the charging base correctly so i adjusted it and made sure it was clean and touching both bars and left it overnight. In the morning i tried to turn it on again…nothing. I tried to do wyze support chat but gave up after 30 minutes of waiting. Tried to do it again on Sunday and gave up again. Sent an email to support. I got an automated response back to try updating my app then logging out and in again. I did that even though i know that will do nothing to the physical vacuum. Monday i tried to call the support number but it had some prerecorded message then hung up on me. Then i got on chat again (which only works from my phone) and waited 25 minutes to talk to someone then 25 more while they looked into the problem. They didn’t give me any tips or troubleshooting to try. He said that he’ll send to the order department for a replacement.

TL:DR - Robot said something and shut off. Now won’t turn back on. Support is hard to get through to and slow to take action.

Any tricks i could try? How long will this take? I know they have limited stock right now. I miss those clean lines in my carpet every morning…especially with a 3 year old rolling around on it all day.

Have you tried the factory reset? Press the home button for about 5 seconds and the vacuum will say “factory reset will start”, then press the home button for another 5 seconds to confirm the factory reset.

I held power button for at least 10 seconds and nothing ever happened. I held both buttons for at least 10 seconds and nothing ever happened.
My guess would be a battery issue. They never even had me try to troubleshoot past the things i told them i already tried.
Wyze sent me a tracking number last night and i should get the replacement today.
I wonder if it will be refurbished vac only or if it will be the whole kit brand new.

I guess it’s not too bad if you can get a brand new replacement :wink:

They sent a brand new replacement and told me to recycle the old one. I would have thought they would ask for the defective one back. That’s good for me because now i have double the brushes and filters and replacement parts. Thanks Wyze. :slight_smile:

1 Like

I’m having the same issue. Mine just keeps spinning but it wasn’t near anything when it went all crazy. Still waiting for assistance.

Has anyone tried to just remove the battery to force a full reset? Sometimes soft power control is not enough, stray voltage can linger and cause things to seem permanently broken. Looks easy to remove the battery, a lot of lithium battery devices make it easy to remove the battery if for the only reason is e-cycle purposes.