Robot Vacuum Shuts Itself Off Immediately

I bought a Wyze robot vacuum for my sister in August. It worked great for a few days, but it no longer works at all: it decides to shut itself off as soon as it starts doing something. We deleted it from the app and did factory reset and setup again, and from that point we can’t do initial mapping or first-time cleaning.

We place it at the charging station, turn it on, and check the app. It shows 97% power. After a bit we try to start mapping or first time cleaning. What usually happens is the robot turns ~27 degrees to the left and then shuts off. Occasionally instead, without shutting off, it pulls off from the charging station, stops, and announces “I must be connected to the charging station to turn off.” It won’t do anything from there. If we nudge the charging station up to connect it, the robot instantly shuts off upon connection.

Things I’ve tried/checked:

  • Power is at 97% according to app
  • factory reset and deleted it from the app and added it again
  • Precise location is on (on iPhone)
  • Wyze is on in local network permissions (on iPhone)
  • Robot is on 2.4 GHz network
  • iPhone is on same 2.4 GHz network
  • Moving the charging station to a new area with 3+ feet clearance left and right and 4.5+ feet clearance in front, all even, smooth hardwood floor
  • cleaned the Lidar tower
  • rebooted wifi router

Time to return it? Any other ideas for how to fix it?

That sounds defective, sorry! :sob:

I would return it to where you got it if you can, if not contact Wyze support for a replacement.

Thanks for the confirmation and guidance. I’ll proceed with that in ~24 hours barring some miracle cure showing up.

1 Like