Robot vacuum docking

New Vac backs into charging dock 2 times then runs away.
Does this multiple times.
Have to shut it down and manually dock it to charge the battery.

I’m having the same issue. The vacuum will act like it’s docking. Slightly back up into the charge connections twice, then act as if it couldn’t dock and move forward to start the process over. Rinse and repeat until the battery runs out.

I ended up having to move my charger to another location.
I believe the problem was the vacuum was "seeing " a piece of furniture in front of it that it felt was too close, eventhough it wasn’t.

Welcome to the Wyze community @theindiearmy! It seems you figured it out! I’d definitely recommend having 5 to 6 inches of clearance on both sides of the charger.

Thank you.
My problem seemed to come from needing more clearance in the front.
I moved it to a place that actually had quite a bit less space than before on the sides but about two feet more clearance in the front.
Works like a charm.

I haven’t figured anything out. I’m still having the same issue. I have well over two feet on every side of the dock save for the wall that it’s backed up against.

Is on the carpet?

Yea, it’s directly on the carpet/floor. I haven’t put anything under the charging station if that’s what you mean.


Docking needs to be done on a hard floor. The dock does not like carpeting. Move it to a hard floor and delete the map so the vac can find the dock.

I don’t have a hard floors. If I had hard floors I would have bought a mop, not a vacuum. There is nothing in the documentation stating the dock needs to be on a hard floor. The map and it finding the dock is fine. It’s just not making a proper connection. Well, it is, but the moment it does it gives up and runs away from the dock and tries again. It works sometimes, but 95% of the time it won’t.

1 Like

Make sure you have 4-5 feet of unobstructed "view " in front of the vac.

It’s got 16 feet as there is nothing between the dock and the other side of the room. I appreciate the help, but I don’t see why any of this matters. It’s not a matter of the vacuum not being able to get to the dock or not having space to find the dock. It literally makes contact with the charging rails and then just jets back out into the room a couple feet and tries again. It’s not an issue of it not being able to get into position to charge. It just needs to stop doing anything when it makes contact with the rails so it can go on charging.

1 Like

I have min on a carpet with no issues. I do know that some carpets were causing issues, but from what @theindiearmy said, hard floors aren’t an option.
What about some Command strips on the charger? You could line it up with the vacuum and then secure it to the wall.

Try resetting the vacuum.

When I don’t do any assistance, the vacuum still makes contact with the rails. I know what you are thinking though and I’ve tried to support the dock with my hand while the vacuum does its thing to assist it in making a “better” connection and line it up better than it already can do on its own and that doesn’t seem to help. The only thing I can do as far as assisting it, rather than pick it up entirely and put it down on the dock, is to nudge it back about half an inch so the charging rails go into the dock more than the vacuum pushes them in on its own. Then charging seems to initial and the vacuum is happy.

I will try that. Does it reset after firmware update? If so, then it’s already been reset a few times. I’ve also redone the entire map a couple times too.

I was talking about a factory reset, but what your describing now is the same thing that mine does. It makes contact and charges even though it looks like it wouldn’t charge. I’m not sure why it does this, but it seems to change with no issues so I just let it do it’s thing.

Mine does not charge. It makes contact for a second, then goes back out into the room a couple feet, spins around to get its bearing, creeps back up to the dock, makes contact for a second again and repeats that process until I help it dock properly, or it runs out of battery.


I have same issue . Charger is on carpet. Nothing in front. I solved by putting charger on shower mat. Hopefully this is temporary solution and charging / retry issue can be fixed in firmware.

I have this exact same issue. I have to manually put it back on. It appears that the charging strips on the vacuum itself are too thin and slip off the strips on the charging station.

1 Like

Having the exact same thing happen as well. Disappointing since we had a Roborock that seated beautifully most every time (if it found its way back that is). We do have it on a low-pile carpet. Again comparing to the Roborock that one didn’t have any issues, but the charging connectors were on the bottom and not the back I think?

Has the mat under the unit helped anyone? We have the charging dock up against the wall and it just touches and then backs out, repeatedly, sometimes finally charging and other times doing this until it runs out of battery and shuts down. Not really acceptable.

I moved mine so that there was nothing within 4’ of the front of the unit and it worked. As for the sides, it doesn’t seem to be near as critical. Mine has table legs within 6" of the sides.