Robot vacuum and wifi 6?

Is there a problem connecting to wifi 6?

First of all, I am a non-techie person so please if you reply keep it simple for the simple-minded.

We just had Spectrum upgrade us to wifi 6 (or something like that. We got a new modem, and the tech said to upgrade our extender to a wifi 6 compatible extender).

Once that happened, our robot vacuum was kicked off wifi and now it won’t connect. When I try to connect, it says “not compatible with 5g”. It doesn’t matter if I try to connect with the regular network and not the one that says 5g, it still won’t let me connect.

I thought maybe it was our 10+ year old router, so we got a new router compatible with wifi 6. It’s dual band, and our extender is dual band. (As was the old one.)

But it still won’t connect. Is there something I’m missing?? I’ve tried a factory reset–no dice.

Sometimes smart devices (like your vacuum) have trouble connecting to dual band Wi-Fi’s. A common fix is to temporarily disable the 5ghz, set the device up again (hold the 2 buttons until it says WiFi reset and go through the app setup process), and once it’s connected re enable 5ghz, and the device should be able to connect again.

In your router there should be a setting to temporarily disable 5ghz.

If you google your router name and model you can find instructions on how to do that


Ya, I did all that. Still says “5g not available”. Wyze support has no idea what to do.

Check that 802.11n is enabled. I doubt it would be disabled by default though. If 2.4ghz radio is turned on, it should be fine.

Also check security settings, make sure WPA2 is available. I don’t think WPA3 is supported by the robot vacuum. This is assuming defaults were changed. I don’t think WPA2 would be disabled by default since it is still commonplace.

I have mine on a dual-band, multi AP, guest, “Wifi 5” network, no complaints.

Another trick is to disable cellular on your phone so it is wifi only, during the setup process. I’ve had to do that before, but I forget if it that was for a Wyze device or not.

It likely means that the stock router your ISP gave you is a crappy router. Most decent routers are able to “route” devices through their appropriate band without problems. The fact that this router isn’t able to do so with all devices (where those same devices are able to work fine on other routers where the SSID has the same name), means that you have a couple of choices.

  • You can change the settings in your router to have a different network name for the 2.4GHz band and a different name for the 5GHz band. Then it won’t have this problem anymore.
  • You can leave your 2 bands sharing the same name but see if your router allows you to set up a Guest network or Virtual LAN of just the 2.4GHz band and use a different name for a separate network/SSID with just 2.4GHZ. Then when you have a device that has problems on the merged network, you can tell it to activate the device on that “Guest” network that only uses 2.4GHz and now everything should work fine.
  • You can get a different router that is able to route devices appropriately even when the 2.4GHz band and the 5GHz band use the same network name. You can use this INSTEAD of the other router, or in addition to it. Though using both at the same time could cause some network interference. Make sure they are using different “Channels” to broadcast at the very least.
  • You can keep the same router using the same SSID name for both bands, but continue to have random devices you get not work sometimes (and probably have to return them) because the router has poor programming.

As far as I see it, those are the best options.

1 Like

Ya, we don’t have the stock router from our ISP. We bought a new one. And our networks have different names. The 5g is named XXX 5g.

1 Like


To answer your question, my vacuum was running on WiFi 6 for over a year without any problems, most of the time on an SSID with the same name.

I have also used a WiFi 6e router without any problems including with a merged SSID name.

If you have a separate SSID name and set it up on just the 2.4GHz band and it’s still not working, that is really weird.

Did you try contacting support yet?

Yes, and they were useless. They didn’t even know the correct way to restore factory settings. I had to tell the guy and he said “Oh you know more than I do.”

In my case, my AP’s have no special routing features turned on. 2.4ghz 802.11n and 5ghz 802.11ac are both using the same SSID and password. My WRV with the older multi-floor beta f/w had no issue figuring it out. So far the only issue I’ve had is some devices capable of 5ghz preferring the 2.4ghz band even though the signal was great (TVs), so I just made a dedicated 5ghz one for them.

Might want to make sure you can still connect it to the old router.

Basic question, when the new router was installed do you know if the same name (SSID) and password was used. The SSID is Case Sensitive, normally, and therefore should be spelled exactly the same.

If the answer is no or you are unsure, then the issue could be that one of those two things, or both, is different. If they are different, then the Wyze products will not connect automatically. You will need to reconnect your devices to the router.

Here is a link to reset the WiFi on the Vacuum:,You’re%20all%20set!