Removing the SD card (Wyze Cam V2)

Got my Wyze V2 camera (my first Wyze camera ever) earlier this week. Decided to try the SD card features, so I inserted the nearest microSD card I had lying around, which was a 4GB card.

All of the SD-card related functions worked just fine (playback, timelapse, etc.). But I decided that if I was going to use those features full-time, I’d want a card with more GBs, so I tried to take the card out. I tried to push on the card as you normally would to eject an SD card, but the visible end of the card was flush to the camera surface so there was nothing to push down. I tried using a pen point and then the end of some tweezers to push on the card, but it still wouldn’t release.

I finally stuck (gently, I thought) one of the tweezer ends into the slot (between the card and the camera) and managed to pop it loose. That was a mistake: I got the card out, but now no card will stay in/engage with the slot - not the card I originally had in there nor another card I tried. So I’m guessing I broke the slot.

Anyone else had trouble getting the SD card out? If it does get stuck like it did for me, learn from my mistake and be careful with what you try in order to get it out…or decide it’s not worth the risk.

1 Like

You may have broken the slot, or you may have just removed the card but left the mechanism in the engaged position.

I would try this… insert one of your cards. Then use another card to push that card in. Hopefully you’ll hear a click and it will release. When engaged normally, the card sits slightly below the surrounding surface. When pushed in all the way to engage/disengage, it is recessed what looks like a little of 1/16 inch.

That worked! I got the other card in and everything looks good. Thanks for the tip.


When I have trouble getting the Micro SDHC out, I use an envelope opener to carefully push the card in to than remove it:



I use a push style staple remover like this (link should open in a new tab/window):

It does not have a point which could damage the card.

I’m unable to push it in any farther, it functioned fine. I tried pushing and pulling a number of ways, including with tiny needlenose pliers, can’t pull it out, can’t get it in farther.

If you can’t push in until it clicks and then release, then it could be a broken mechanism. Probably need to start a support ticket on it.