Anyone else having trouble getting SD card to stay in?

HI All,

Just thought I’d ask about this. I want to put a Sandisk Class 10 32 Gig SD card in my new V2 Camera. I watched the videos about how this particular camera wants its card. Really the same as everything else I own, so I moved the stand out of the way and put the micro card in label face up and used my thumb nail to push it in and expected to hear and feel a click. Not happening. So I went through the videos again and saw where it does need to go in a ways and to use the tip of a pen. I put the card in again and then used to pen tip to gently push in on the card, still nothing, no click to hear or feel and the card pops back out. I have tried three different cards and none of them will stay put.

What could be wrong? Is anyone else having any trouble?


Thanks much for any help or advice. :slight_smile:

I’m not an expert but I think you shouldn’t hear a click when installing the card. Just press it in until it stops. Then check the app to see if the camera sees the card.

If you press it further it compresses a spring that pushes it out. That makes a click. I suspect that is what is happening to you.

Some of the cams had shipped with the card slot mechanism “pre engaged”, so you had to insert the card all the way, then push again to make it eject (with a click), then insert it one more time to get it to click into place. When fully inserted, the edge of the card is every so slightly below the surface surrounding the slot.

Thanks for the input! On my other devices I feel and sometimes hear a small click when I put in a card, and it stays in place when I take my finger off of it. I tried to just slide the card in, it was still hanging out the bottom of the camera and then plugged it back in and checked the app and nothing, no SD card. I didn’t want to play with pushing the card in while it was still plugged in so I unplugged it again and slid the card back out. It just came out, no pushing it in for it to disengage. Thanks very much for trying, appreciate it! :slight_smile:

Thank you RickO, I see what you are saying but there is no engagement at all. No matter how far I push it in and I’m scared to death to push to hard, it will not stay, will not engage at all just pushes right back out. Mercy, I have never had this much trouble from such a little thing as this slot! :slight_smile: I have looked at it with a strong light to see if anything could be in the way and it seems that I may be seeing some kind of small white/greenish maybe thread like items, very small, on the right hand side of the slot. Don’t know if that could even have anything to do with it. I have checked all my cards in my other devices and they all slide in, click and stay and then push in click and pop out so I’m fairly certain it’s not them.

So nice to have an active forum like this. Thanks very much!!

I think at this point, you will need to contact Wyze support.

yeah Rick I think I will as well. Thought I would give the forum a try first. It must be something I’ve either not done and am doing wrong, just never had trouble with an SD slot before. Thanks all for the ideas and help.

Hello All, wanted to update this. After talking to Customer Service there really is something wrong with the SD Slot, very rare but as usual if it can happen it’s going to happen to me! :smiley:

Customer Service was very nice and they are going to replace my unit for me. In the mean time I have so much faith in this company and the people behind it that I went ahead and ordered two more.

Take care and stay safe!


My sd cards won’t stay inserted into either one of my two cameras.

It sounds like you’re not inserting them far enough into the slot. Use a fingernail, or something thin to push the card the rest of the way in. Don’t push too hard.


I have had the same problem with a v2 cam I recently purchased and the warranty replacement camera sent to me by Wyze. I purchased a third cam but am not very hopeful as this problem appears to be epidemic after reviewing multiple threads outside of Wyze.

Just in case you haven’t tried this, are you inserting the SD card label up (towards the edge of the camera) in the slot?

I pushed the cards in a dozen times with no results. After reading this board, I took an eyeglasses screwdriver and gently pushed the card in, reinserted the usb cord, and TA-DA, the cameras now see the card. Thanks for the advice!

I realize you’ve probably fixed this by now, but for other lurkers like myself. I had a hard time getting it to “click” and even used the flat end of a colored pencil, but it didn’t want to stay in. I went whole hog and pressed hard with the pencil and finally got the “click” I needed.

Just press pretty hard and it should go in. Label out facing toward the lens.

The spring in mine is super strong - it’s a real battle to get the SD card to stay in. Likewise, ejecting it causes it to shoot a few feet across the room.

same problem - it does not want to stay in properly

Does yours say less than 100 M available when it wont click in?

October 2022, still a problem. Took out sd card to copy files, now it won’t stay in. Push hard, push soft, wiggle while pushing. Tried different sd cards, no luck. Bummer.