Wyzecam V2 never able to see SD card(s)

I received a Wyzecam V2 and have been using it as a baby camera for 6+ months. My wife and I love it. However, I was never able to install an SD card in it and have it show up at all under “Local Storage” in the app. I’ve tried many different kinds of SD cards (all of which work fine on a GoPro and Insta360 X), and different kinds of format (FAT32, exFAT, PC, Mac, SD Card Formatter from sdcard.org). I even purchased one from Wyze to no avail. Every time, the app says “No SD Card” under “SD card memory available” line in “Local Storage” tab. Is my Wyzecam V2 faulty?

Wyzecam V2

Does the card “click” in when pushed far enough?
I had one cam (out of 15) that it was a bear to push the card in till it clicked. After about 3 times it “loosened up”.
Some of them a simple push with my fingernail works, most require using the flat edge of a knife.

All the SD cards I’ve tried certainly do “click” into place.

I tried to power down the camera, insert the card, and power on again… still no joy. No chime, or ding. And now the 32GB card shows up as 2GB on my computers and refuses to be formatted to it’s original capacity… Sigh… going to get a support ticket now. This is sad and annoying…

I have 4 of each camera. For some reason, I can NEVER format the 64G in the pan-tilt camera. Never works, But, if I put the sd card into the regular camera, it formats great. Then I take the sd out, and put it into the pan-tilt cam. If you have a regular camera, they are cheap, you can try this.

sounds like your camera is faulty.
I’ve experienced the exact same problem on multiple cams from my recent order

If anyone has a problem about no SD card issue, check that your Wyze V2 is eligible for replacement .