Refresh Tokens Not Working

Is it just me? I have been using home assistant integration and it keeps making me log back in. I tried in python using the wyze-sdk package and got the same error. I finally just called the endpoints manually in python using requests and i get the same errors. Below is what I’m getting:

{‘code’: ‘2002’, ‘ts’: 1720371214381, ‘msg’: ‘refresh token is error.’, ‘data’: {}, ‘traceId’: ‘c60d3ea23395529a2e5a9a6683fa01f5’}

1 Like

OMG I had this problem for all of April and May in the SecKatie Wyze HACS API. I had to re-login at least once a day, sometimes more often for more than a month, and I think it was 2 months. Drove me insane.

I’m not entirely sure how I got it fixed as I tried so many things, but eventually after some update, it was finally fixed.

I talked to someone else who was having this issue last year, but they too had theirs suddenly resolve itself one day.

I think mine was actually fixed after a random Home Assistant Update, rather than the Wyze API update. I don’t know if it was the CORE update or OS update, and I don’t know if some of the other million things I tried helped or not, but it eventually got resolved. Wish I could give you more help.

All I can really tell you is that you aren’t the only one who has had this happen. You’re the 3rd person I know of. But I don’t know anyone else having this happen right now. Mine got fixed sometime in May or early June at the latest.

I never saw the error, I just know I had to keep logging back in every day and it was reducing my sanity.

Sounds like it is probably the same, i suspect something with my user on the wyze side, but who knows. Hopefully it’ll fix itself soon

1 Like